Bug #17589: Cant load dynamic modules becouse of "executor_globals" problem
From: dawszy@tgr.lubin.edu.pl
Operating system: NetBSD
PHP version: 4.2.1
PHP Bug Type: Apache2 related
Bug description: Cant load dynamic modules becouse of "executor_globals" problem
Here you go, it happens with every module compiled and
added to php.ini.
Dont have a clue what may couse it;[
Help please?
PHP Warning: Unable to load dynamic library
'/usr/pkg/lib/php/extensions/no-debug-zts-20020429/mysql.so' -
/usr/pkg/lib/php/extensions/no-debug-zts-20020429/mysql.so: Undefined
symbol "executor_globals" (reloc type = 6, symnum = 164) in Unknown on
line 0
PHP Warning: Unable to load dynamic library
'/usr/pkg/lib/php/extensions/no-debug-zts-20020429/pcre.so' -
/usr/pkg/lib/php/extensions/no-debug-zts-20020429/pcre.so: Undefined
symbol "executor_globals" (reloc type = 6, symnum = 97) in Unknown on line
0
[Tue Jun 04 11:15:45 2002] [notice] Digest: generating secret for digest
authentication ...
[Tue Jun 04 11:15:45 2002] [notice] Digest: done
[Tue Jun 04 11:15:46 2002] [notice] Apache/2.0.36 (Unix) mod_ssl/2.0.36
OpenSSL/0.9.6b DAV/2 PHP/4.2.1 configured -- resuming normal operations
--
Edit bug report at http://bugs.php.net/?id=17589&edit=1
--
Fixed in CVS: http://bugs.php.net/fix.php?id=17589&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=17589&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=17589&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=17589&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=17589&r=support
Expected behavior: http://bugs.php.net/fix.php?id=17589&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=17589&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=17589&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=17589&r=globals
Thread (9 messages)
- dawszy at tgr dot lubin dot edu dot pl