Re: cvs: php4 /ext/gd gd.c
| From: | Andi Gutmans | Date: | Fri, 11 Oct 2002 12:32:22 +0000 |
| Subject: | Re: cvs: php4 /ext/gd gd.c | ||
| References: | 1 | Groups: | php.cvs |
| Request: | Send a blank email to php-cvs+get-14818@lists.php.net to get a copy of this message | ||
I don't think this is a good idea. I'd definitely change the name to GD_something but it still doesn't make so much sense to me. When would people use this and not function_exists()?
Andi
At 09:49 AM 10/11/2002 +0000, Derick Rethans wrote:
derick Fri Oct 11 05:49:38 2002 EDTModified files:/php4/ext/gd gd.cLog: - Add indetified for bundled GD Index: php4/ext/gd/gd.c diff -u php4/ext/gd/gd.c:1.214 php4/ext/gd/gd.c:1.215--- php4/ext/gd/gd.c:1.214 Thu Sep 19 21:25:55 2002 +++ php4/ext/gd/gd.c Fri Oct 11 05:49:38 2002@@ -18,7 +18,7 @@+----------------------------------------------------------------------+*/ -/* $Id: gd.c,v 1.214 2002/09/20 01:25:55 iliaa Exp $ */ +/* $Id: gd.c,v 1.215 2002/10/11 09:49:38 derick Exp $ */ /* gd 1.2 is copyright 1994, 1995, Quest Protein Database Center,Cold Spring Harbor Labs. */@@ -346,6 +346,9 @@REGISTER_LONG_CONSTANT("IMG_EFFECT_ALPHABLEND", gdEffectAlphaBlend, CONST_CS | CONST_PERSISTENT); REGISTER_LONG_CONSTANT("IMG_EFFECT_NORMAL", gdEffectNormal, CONST_CS | CONST_PERSISTENT); REGISTER_LONG_CONSTANT("IMG_EFFECT_OVERLAY", gdEffectOverlay, CONST_CS | CONST_PERSISTENT); + REGISTER_LONG_CONSTANT("HAVE_BUNDLED_GD", 1, CONST_CS | CONST_PERSISTENT);+#else+ REGISTER_LONG_CONSTANT("HAVE_BUNDLED_GD", 0, CONST_CS | CONST_PERSISTENT);#endifreturn SUCCESS;} -- PHP CVS Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php