Re: PHP can't lose to Micro$oft - Please HELP!
| From: | John Lim | Date: | Thu, 11 Oct 2001 16:37:04 +0000 |
| Subject: | Re: PHP can't lose to Micro$oft - Please HELP! | ||
| References: | 1 2 3 | Groups: | php.db |
| Request: | Send a blank email to php-db+get-13260@lists.php.net to get a copy of this message | ||
I agree with Steve.
Iif informix (which I know nothing about) supports connection pooling
internally,
there is no performance advantage in using persistent connections - instead
resource
starvation can occur.
Regards, John
Steve Brett <steve.brett@e-mis.com> wrote in message
news:20011011112254.46695.qmail@pb1.pair.com...
> haven't used informix and i would certainly recommend postgresql (i use it
> at work) ....
>
> from looking at your code your problem may lie here:
>
> > > $connect_id_roll = ifx_pconnect($dbs,$login,$password); <--
Line
> > >51 --|
>
> you are using a persistent connection. i fell into this trap a while ago
> with an app accessed by around 200 users and found that it caused problems
> with multiple intances on postgresql being spawned when the load indicated
> it wasn't needed.
>
> i did some digging and discovered persistant connections are not a good
idea
> and should only be used where the latency with connections were high.
>
> as soon as i changed it the problem went away.
>
> hope this helps,
>
> Steve
>
> "Jason G." <blair@nb.net> wrote in message
> news:5.1.0.14.0.20011011011917.02b810f8@pop3.nb.net...
> > I do not know much about informix, but personally, if MySQL or
PostgreSQL
> > is better, then who cares how much you spent on informix. Use the best
> > tool for the job!
> >
> >
> > At 10:11 PM 10/10/2001 -0700, Notmy Realname wrote:
> > >Situation:
> > >
> > >Small software company is at a cross-road. Do we use ASP (Win 2k, IIS,
> > >VB...) or PHP (UNIX, Apache...). Currently we have two teams working on
> > >prototypes for this project. The Micro$oft pets (ASP) vs. the PHP
> > >free-spirits (btw, PHP is way ahead in features implemented!). Good vs.
> > >Evil, right? :)
> > >
> > >Anyway, THE PROBLEM:
> > >
> > >We use INFORMIX IDS 7.3 (Windows) for db. Can't change that (spent to
> much
> > >money on it). The problem we are having is this:
> > >
> > >We create a persistent connection with the Informix server:
> > >
> > > $database = "tst22";
> > > $server = "some_db_server";
> > > $login = "blah";
> > > $password = "blabblah";
> > >
> > > $dbs = $database."@".$server;
> > >
> > > $connect_id_roll = ifx_pconnect($dbs,$login,$password); <--
Line
> > >51 --|
> > >
> > > if (!$connect_id_roll) {
> > > echo "Unable to connect to Informix database<br>\n";
> > > chk_ifx_err1($connect_id_roll);
> > > }
> > > ... (our code)
> > >
> > >This works fine; most of the time that is, until we get this (somewhat
> > >randomly):
> > >
> > >Warning: E [SQLSTATE=08 002 SQLCODE=-1802] in
> > >d:\apache_webdocs\php_demo\roll_list.php on line 51
> > >Unable to connect to Informix database
> > >
> > >Informix error: E [SQLSTATE=08 002 SQLCODE=-1802]
> > >
> > >Connection name in use.
> > >
> > >The ifx_error function return the following string:
> > >
> > >x [SQLSTATE = aa bbb SQLCODE=cccc]
> > >
> > >where x = space : no error
> > >E : error
> > >N : no more data
> > >W : warning
> > >? : undefined
> > >W : warning
> > >
> > >So, until we fix this problem we can't proceed to develop the reset of
> the
> > >application the boss says, which is quite understandable, and of course
> the
> > >other team is closing in (although buggy as hell) we can't afford to
let
> the
> > >Micro$oft script kitties win this one, can we?! Please help.
> > >
> > >Thanks in advance,
> > >
> > >Anonymouse Self
> > >
> > >
> > >
> > >--
> > >PHP Database Mailing List (http://www.php.net/)
> > >To unsubscribe, e-mail: php-db-unsubscribe@lists.php.net
> > >For additional commands, e-mail: php-db-help@lists.php.net
> > >To contact the list administrators, e-mail:
php-list-admin@lists.php.net
> >
>
>