Re: OpenSSL version requirements
| From: | Anil Madhavapeddy | Date: | Sun, 07 Jan 2001 10:01:24 +0000 |
| Subject: | Re: OpenSSL version requirements | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-43224@lists.php.net to get a copy of this message | ||
Quoting Jani Taskinen <sniper@iki.fi>:
> On Fri, 5 Jan 2001, Stig Venaas wrote:
>
> >It's not so hard to make the OpenSSL extension work with 0.9.5a
> >I think. The problem is that some functions return error codes
> >in 0.9.6 (which PHP uses) while in 0.9.5a they don't. By making
> >PHP not check for those, it should work.
>
> Why not using this instead of #if 0:
>
> #if OPENSSL_VERSION_NUMBER >= 0x0090600fL
>
> And then we can remove the version check from configure?
> Or change the required version to 0.9.5 ?
>
That would be really useful to us! One other problem I'm having at
the moment while testing out that patch is the fact that --with-snmp
actually overrides '--with-openssl=no'.
The snmp config.m4 checks to see if the SNMP daemon installed was
compiled with OpenSSL support, and if it was, it always calls
PHP_SETUP_OPENSSL.
Of course, the OpenBSD snmp daemon was compiled against OpenSSL-0.9.5a
instead of 0.9.6, and so configuring with --with-snmp always tries
to pull in OpenSSL, which means that the configuration always fails.
--
Anil Madhavapeddy, <anil@recoil.org>