Re: OpenSSL version requirements
| From: | Stig Venaas | Date: | Sun, 07 Jan 2001 10:20:57 +0000 |
| Subject: | Re: OpenSSL version requirements | ||
| References: | 1 2 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-43228@lists.php.net to get a copy of this message | ||
On Sun, Jan 07, 2001 at 10:01:24AM +0000, Anil Madhavapeddy wrote:
> Quoting Jani Taskinen <sniper@iki.fi>:
> > On Fri, 5 Jan 2001, Stig Venaas wrote:
> >
> > >It's not so hard to make the OpenSSL extension work with 0.9.5a
> > >I think. The problem is that some functions return error codes
> > >in 0.9.6 (which PHP uses) while in 0.9.5a they don't. By making
> > >PHP not check for those, it should work.
> >
> > Why not using this instead of #if 0:
> >
> > #if OPENSSL_VERSION_NUMBER >= 0x0090600fL
> >
> > And then we can remove the version check from configure?
> > Or change the required version to 0.9.5 ?
Yes, it will require more work to get it working with older than 0.9.5
I think.
> That would be really useful to us! One other problem I'm having at
> the moment while testing out that patch is the fact that --with-snmp
> actually overrides '--with-openssl=no'.
>
> The snmp config.m4 checks to see if the SNMP daemon installed was
> compiled with OpenSSL support, and if it was, it always calls
> PHP_SETUP_OPENSSL.
>
> Of course, the OpenBSD snmp daemon was compiled against OpenSSL-0.9.5a
> instead of 0.9.6, and so configuring with --with-snmp always tries
> to pull in OpenSSL, which means that the configuration always fails.
I knew the snmp-part did this, but didn't realise the problem with
version check related to this. I'll make it work with 0.9.5a, just
give me an hour or so (:
Stig