Bug #13058 Updated: opendir fails on remote folders with apache as a service
| From: | nicolas_toniazzi at hotmail dot com | Date: | Thu, 30 Aug 2001 13:14:25 +0000 |
| Subject: | Bug #13058 Updated: opendir fails on remote folders with apache as a service | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-64708@lists.php.net to get a copy of this message | ||
ID: 13058
User updated by: nicolas_toniazzi@hotmail.com
Reported By: nicolas_toniazzi@hotmail.com
Old Status: Feedback
Status: Open
Bug Type: Apache related
Operating System: WindowsNT
PHP Version: 4.0.6
New Comment:
I'm sorry, I read the doc but still don't understand the differences between module and
cgi...
I simply use the default setup given with EasyPHP 1.5.
When I noticed the problem, I had all the rights I had ever dreamed of (in fact, I could read from
and write to the folder). If the problem came from permissions, wouldn't the error say
something about it? I read from users who had those problems with IIS.
Previous Comments:
------------------------------------------------------------------------
[2001-08-30 08:57:38] dbeu@php.net
have you setup proper access permissions?
are you using the module or the cgi?
if the webserver starts as service it will most likly run under SYSTEM, otherwise as the currently
logged on user.
------------------------------------------------------------------------
[2001-08-30 08:02:18] nicolas_toniazzi@hotmail.com
I'm using php, apache and mysql from EasyPHP 1.5 with windowsNT.
When launching the servers as services, the opendir command fails with remote folders :
opendir("//machine/folder"); returning an "errno 22" error.
When running the servers "normally", everything goes well (as far as I tried).
------------------------------------------------------------------------
Edit this bug report at http://bugs.php.net/?id=13058&edit=1