Re: cvs: php4 /ext/domxml config.m4 php_domxml.c php_domxml.h

From: Date: Tue, 08 Jan 2002 20:25:11 +0000
Subject: Re: cvs: php4 /ext/domxml config.m4 php_domxml.c php_domxml.h
References: 1 2  Groups: php.cvs php.dev 
Request: Send a blank email to php-dev+get-76281@lists.php.net to get a copy of this message
On Tue, Jan 08, 2002 at 06:25:06PM +0100, Jaroslaw Kolakowski wrote : > > > Just to be really picky, but shouldn't these functions be named > > > html_doc(), html_doc_file() and domxml_html_dump_mem() ? > > > > > > I understand that we already have xmldoc(), xmldocfile(), xmltree() and > > > even domxml_dumpmem(), but I still think we should stick we the coding > > > standards. It is an extra good thing that this extensions is still > > > experimental so we don't have to worry about BC that much. > > > > > > Am I totally off base here ? > > > > +1 here. > > OK. I will change it. > > And what about changing names of xmldoc(), xmldocfile(), > xmltree() and domxml_dumpmem() then? If the code is > experimental, it would be only naughty, but not forbidden. Too late, the API was already in the last official release. If you care, you can rename them but you'll have to maintain an FALIAS for each. -- Please always Cc to me when replying to me on the lists.

« previous php.dev (#76281) next »