Re: proposed domxml funciton name changes:
| From: | 'Ricky' S Dhatt | Date: | Fri, 05 Apr 2002 22:32:19 +0000 |
| Subject: | Re: proposed domxml funciton name changes: | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-82156@lists.php.net to get a copy of this message | ||
I think "consistency" depends on your point of view.
I'm guessing the current function names are based off the W3C DOM Spec:
insertBefore:
http://www.w3.org/TR/2002/WD-DOM-Level-3-Core-20020114/core.html#ID-952280727
appendChild:
http://www.w3.org/TR/2002/WD-DOM-Level-3-Core-20020114/core.html#ID-184E7107
--Ricky
On Fri, 5 Apr 2002, Joseph Tate wrote:
> I propose the following function name changes for clarity and consistency:
>
> Rename:
> domxml_node_insert_before -> domxml_node_insert_node
> domxml_node_append_child -> domxml_node_append_node
>
>
> Remove:
> alias to unlink (in favor of the more consistent unlink_node)
> domxml_node_new_child() (in favor of a domxml_doc_create_*
> domxml_node_add_child() combination)
>
>
> If I've misunderstood what something does, or why it's named in such a way,
> let me know.
>
> Joseph
>
>
> --
> PHP Development Mailing List <http://www.php.net/>
> To unsubscribe, visit: http://www.php.net/unsub.php
>
>