Re: proposed domxml funciton name changes:

From: Date: Sat, 06 Apr 2002 08:33:26 +0000
Subject: Re: proposed domxml funciton name changes:
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-82181@lists.php.net to get a copy of this message
In <LMEBIGPOOEGLDHJJGLBBMELOFAAA.jtate@mi-corporation.com>, Joseph Tate wrote: > I propose the following function name changes for clarity and > consistency: > > Rename: > domxml_node_insert_before -> domxml_node_insert_node > domxml_node_append_child -> domxml_node_append_node I agree here with Ricky. Please stick to the W3C DOM Proposals as much as possible. The domxml extension has already a lot of functions and it would be really a PITA if PHP would use other names than everyone else for DOM-functionality... > Remove: > alias to unlink (in favor of the more consistent unlink_node) > domxml_node_new_child() (in favor of a domxml_doc_create_* > domxml_node_add_child() combination) No no no :) Don't remove any functions without really good intentions. It will break a lot of my scripts (domxml_node_new_child() doesn't look like a w3c reco. but anyway, i assume a lot of people use it ...) chregu

« previous php.dev (#82181) next »