New SNMP function names

From: Date: Wed, 04 Dec 2002 13:49:16 +0000
Subject: New SNMP function names
Groups: php.dev 
Request: Send a blank email to php-dev+get-92066@lists.php.net to get a copy of this message
Hello, while browsing the CVS I found that the following functions were added to the CVS recently: + PHP_FE(snmpv3get, NULL) + PHP_FE(snmpv3walk, NULL) + PHP_FE(snmpv3realwalk, NULL) + PHP_FALIAS(snmpv3walkoid, snmpv3realwalk, NULL) + PHP_FE(snmpv3set, NULL) But those functionnames don't adhere to our nameing guidelines. As those are new functions I propose to change them to the following, to be more consistent with all other functions: snmpv3get -> snmp3_get snmpv3walk -> snmp3_walk snmpv3realwalk -> snmp3_real_walk (or snmp3_walk_oid) snmpv3set -> snmp3_get also, there is no need to introduce an alias for a newly created function so I guess we just should drop it. I'd like to make those proposed changes ASAP as they are also added in the PHP_4_3 branch which gets closer to release everyday. regards, Derick -- ------------------------------------------------------------------------- Derick Rethans http://derickrethans.nl/ JDI Media Solutions http://www.jdimedia.nl/ PHP Magazine - PHP Magazine for Professionals http://php-mag.net/ -------------------------------------------------------------------------

« previous php.dev (#92066) next »