RE: [PHP-DEV] New SNMP function names
| From: | John Coggeshall | Date: | Wed, 04 Dec 2002 21:06:27 +0000 |
| Subject: | RE: [PHP-DEV] New SNMP function names | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-92085@lists.php.net to get a copy of this message | ||
+1
>-----Original Message-----
>From: Ilia A. [mailto:ilia@prohost.org]
>Sent: Wednesday, December 04, 2002 3:23 PM
>To: Derick Rethans; PHP Developers Mailing List
>Subject: Re: [PHP-DEV] New SNMP function names
>
>
>Consistency is always good and adding aliases for newly added
>functions seems
>like a recipe for bloat & confusion.
>+1 on the proposed changes.
>
>Ilia
>
>On December 4, 2002 08:49 am, Derick Rethans wrote:
>> Hello,
>>
>> while browsing the CVS I found that the following functions
>were added
>> to the CVS recently:
>>
>> + PHP_FE(snmpv3get, NULL)
>> + PHP_FE(snmpv3walk, NULL)
>> + PHP_FE(snmpv3realwalk, NULL)
>> + PHP_FALIAS(snmpv3walkoid, snmpv3realwalk, NULL)
>> + PHP_FE(snmpv3set, NULL)
>>C
>> But those functionnames don't adhere to our nameing guidelines. As
>>those are new functions I propose to change them to the
>following, to
>>be more consistent with all other functions:
>>
>> snmpv3get -> snmp3_get
>> snmpv3walk -> snmp3_walk
>> snmpv3realwalk -> snmp3_real_walk (or snmp3_walk_oid)
>> snmpv3set -> snmp3_get
>>
>> also, there is no need to introduce an alias for a newly created
>> function so I guess we just should drop it.
>>
>> I'd like to make those proposed changes ASAP as they are
>also added in
>> the PHP_4_3 branch which gets closer to release everyday.
>>
>> regards,
>> Derick
>
>
>
>--
>PHP Development Mailing List <http://www.php.net/>
>To unsubscribe, visit: http://www.php.net/unsub.php
>
>