cvs: phpdoc-de /reference/datetime book.xml configure.xml constants.xml ini.xml reference.xml setup.xml
| From: | Hartmut Holzgraefe | Date: | Sun, 09 Mar 2008 13:36:06 +0000 |
| Subject: | cvs: phpdoc-de /reference/datetime book.xml configure.xml constants.xml ini.xml reference.xml setup.xml | ||
| Groups: | php.doc.de | ||
| Request: | Send a blank email to doc-de+get-2476@lists.php.net to get a copy of this message | ||
hholzgra Sun Mar 9 13:36:06 2008 UTC
Added files:
/phpdoc-de/reference/datetime book.xml configure.xml constants.xml
ini.xml setup.xml
Modified files:
/phpdoc-de/reference/datetime reference.xml
Log:
file split and translation update
http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/reference.xml?r1=1.12&r2=1.13&diff_format=u Index: phpdoc-de/reference/datetime/reference.xml diff -u phpdoc-de/reference/datetime/reference.xml:1.12 phpdoc-de/reference/datetime/reference.xml:1.13 --- phpdoc-de/reference/datetime/reference.xml:1.12 Sun Mar 9 13:08:57 2008 +++ phpdoc-de/reference/datetime/reference.xml Sun Mar 9 13:36:06 2008 @@ -1,76 +1,15 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.12 $ --> -<!-- EN-Revision: 1.6 Maintainer: betz Status: ready --> -<!-- Purpose: calendar --> -<!-- Membership: core --> +<!-- $Revision: 1.13 $ --> +<!-- EN-Revision: 1.17 Maintainer: hholzgra Status: ready --> - <reference xml:id="ref.datetime" xmlns="http://docbook.org/ns/docbook"> - <title>Datums- und Zeit-Funktionen</title> - <titleabbrev>Datum/Zeit</titleabbrev> - <partintro> - <section xml:id="datetime.intro"> - &reftitle.intro; - <para> - Diese Funktionen ermöglichen es Ihnen, Datums- - und Zeitangaben vom Server, auf dem PHP läuft, abzufragen. - Die Ausgabe von Datums- und Zeitangaben kann mit Hilfe dieser Funktionen - in unterschiedlichster Weise formatiert werden. - </para> - <note> - <simpara> - Beachten Sie bitte, dass diese Funktionen von den lokalen - Systemeinstellungen Ihres Servers abhängen. Ein besonderes Augenmerk - sollten Sie auf Sommer- und Winterzeit (nutzen Sie z.B. - <literal>$date = strtotime('+7 days', $date)</literal> und nicht - <literal>$date += 7*24*60*60</literal>) - und Schaltjahre haben. - </simpara> - </note> - <note> - <simpara> - Die in diesem Abschnitt referenzierten Zeitzonen können in - <xref linkend="timezones"/> gefunden werden. - </simpara> - </note> +<reference xml:id="ref.datetime" xmlns="http://docbook.org/ns/docbook" xmlns:xlink="http://www.w3.org/1999/xlink"> + <title>Date and Time &Functions;</title> + <titleabbrev>Date/Time</titleabbrev> - </section> - - <section xml:id="datetime.required"> - &reftitle.required; - &no.requirement; - </section> - - <section xml:id="datetime.installation"> - &reftitle.install; - &no.install; - <note> - <simpara> - Die jeweils aktuellste Version der Zeitzonen-Datenbank kann über das - PECL Paket - <link href="&url.pecl.package.get;timezonedb">timezonedb</link> - installiert werden. - Für Windows Benutzer stehet eine vorkompilierte DLL auf der PECL4Win - Website bereit: - <link href="&url.pecl.timezonedb.dll;">php_timezonedb.dll</link>. - </simpara> - </note> - </section> - - <section xml:id="datetime.resources"> - &reftitle.resources; - &no.resource; - </section> - - <section xml:id="datetime.constants"> - &reftitle.constants; - &no.constants; - </section> - - </partintro> + &reference.datetime.entities.functions; -&reference.datetime.entities.functions; +</reference> - </reference> <!-- Keep this comment at the end of the file Local variables: mode: sgml @@ -91,3 +30,4 @@ vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> + http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/book.xml?view=markup&rev=1.1 Index: phpdoc-de/reference/datetime/book.xml +++ phpdoc-de/reference/datetime/book.xml <?xml version="1.0" encoding="iso-8859-1"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.2 Maintainer: hholzgra Status: ready --> <!-- Purpose: calendar --> <!-- Membership: core --> <book xml:id="book.datetime" xmlns="http://docbook.org/ns/docbook" xmlns:xlink="http://www.w3.org/1999/xlink"> <title>Datum und Uhrzeit</title> <!-- {{{ preface --> <preface xml:id="intro.datetime"> &reftitle.intro; <para> Diese Funktionen ermöglichen es Ihnen, Datums- und Zeitangaben vom Server, auf dem PHP läuft, abzufragen. Die Ausgabe von Datums- und Zeitangaben kann mit Hilfe dieser Funktionen in unterschiedlichster Weise formatiert werden. </para> <note> <simpara> Beachten Sie bitte, dass diese Funktionen von den lokalen Systemeinstellungen Ihres Servers abhängen. Ein besonderes Augenmerk sollten Sie auf Sommer- und Winterzeit (nutzen Sie z.B. <literal>$date = strtotime('+7 days', $date)</literal> und nicht <literal>$date += 7*24*60*60</literal>) und Schaltjahre haben. </simpara> </note> <note> <simpara> Die in diesem Abschnitt referenzierten Zeitzonen können in <xref linkend="timezones"/> gefunden werden. </simpara> </note> </preface> <!-- }}} --> &reference.datetime.setup; &reference.datetime.constants; <!-- FIXME: Apparently this extension defines a class.. --> &reference.datetime.reference; </book> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/configure.xml?view=markup&rev=1.1 Index: phpdoc-de/reference/datetime/configure.xml +++ phpdoc-de/reference/datetime/configure.xml <?xml version="1.0" encoding="utf-8"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.1 Maintainer: hholzgra Status: ready --> <section xml:id="datetime.installation" xmlns="http://docbook.org/ns/docbook" xmlns:xlink="http://www.w3.org/1999/xlink"> &reftitle.install; &no.install; <note> <title>Aktualisieren der Zeitzonen-Datenbank</title> <simpara> Die jeweils aktuellste Version der Zeitzonen-Datenbank kann über das PECL Paket <link href="&url.pecl.package.get;timezonedb">timezonedb</link> installiert werden. Für Windows Benutzer stehet eine vorkompilierte DLL auf der PECL4Win Website bereit: <link href="&url.pecl.timezonedb.dll;">php_timezonedb.dll</link>. </simpara> </note> <note> <title>Experimental DateTime support in PHP 5.1.x</title> <para> Obwohl die Klasse <classname>DateTime</classname> (und damit zusammenängende Funktionen) erst seit PHP 5.2.0 standardmäÃig aktiviert sind ist es möglich experimentellen Support hierfür bereits in PHP 5.1.x mit Hilfe des volgenden Flags vor <literal>configure</literal> zu aktivieren: <literal>CFLAGS=-DEXPERIMENTAL_DATE_SUPPORT=1</literal> </para> </note> </section> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/constants.xml?view=markup&rev=1.1 Index: phpdoc-de/reference/datetime/constants.xml +++ phpdoc-de/reference/datetime/constants.xml <?xml version='1.0' encoding='iso-8859-1'?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.12 Maintainer: hholzgra Status: ready --> <appendix xml:id="datetime.constants" xmlns="http://docbook.org/ns/docbook"> &reftitle.constants; <para> Die folgenden Konstanten sind ab PHP 5.1.1 definiert und bieten vorbereitetet Standard-Datenformate, diese können zusammen mit den Datumsfunktionen (wie <function>date</function>) eingesetzt werden. </para> <variablelist> <varlistentry> <term> <constant>DATE_ATOM</constant> (<type>string</type>) </term> <listitem> <simpara> Atom Format (z.B. 2005-08-15T15:52:01+00:00) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_COOKIE</constant> (<type>string</type>) </term> <listitem> <simpara> HTTP Cookie Format (z.B. Monday, 15-Aug-05 15:52:01 UTC) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_ISO8601</constant> (<type>string</type>) </term> <listitem> <simpara> ISO-8601 (z.B. 2005-08-15T15:52:01+0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC822</constant> (<type>string</type>) </term> <listitem> <simpara> RFC 822 (z.B. Mon, 15 Aug 05 15:52:01 +0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC850</constant> (<type>string</type>) </term> <listitem> <simpara> RFC 850 (z.B. Monday, 15-Aug-05 15:52:01 UTC) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC1036</constant> (<type>string</type>) </term> <listitem> <simpara> RFC 1036 (z.B. Mon, 15 Aug 05 15:52:01 +0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC1123</constant> (<type>string</type>) </term> <listitem> <simpara> RFC 1123 (z.B. Mon, 15 Aug 2005 15:52:01 +0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC2822</constant> (<type>string</type>) </term> <listitem> <simpara> RFC 2822 (Mon, 15 Aug 2005 15:52:01 +0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC3339</constant> (<type>string</type>) </term> <listitem> <simpara> Entspricht <constant>DATE_ATOM</constant> (since PHP 5.1.3) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RSS</constant> (<type>string</type>) </term> <listitem> <simpara> RSS (Mon, 15 Aug 2005 15:52:01 +0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_W3C</constant> (<type>string</type>) </term> <listitem> <simpara> World Wide Web Consortium (z.B. 2005-08-15T15:52:01+00:00) </simpara> </listitem> </varlistentry> </variablelist> <para> Die folgenden Konstanten existieren seit PHP 5.1.2, sie spezifizieren Rückgabeformate für die Funktionen <function>date_sunrise</function> und <function>date_sunset</function>. </para> <variablelist> <varlistentry> <term> <constant>SUNFUNCS_RET_TIMESTAMP</constant> (<type>integer</type>) </term> <listitem> <simpara> Timestamp </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>SUNFUNCS_RET_STRING</constant> (<type>integer</type>) </term> <listitem> <simpara> Stunde:Minute (z.B. 08:02) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>SUNFUNCS_RET_DOUBLE</constant> (<type>integer</type>) </term> <listitem> <simpara> Sunden als FlieÃkommawert (z.B. 8.75) </simpara> </listitem> </varlistentry> </variablelist> </appendix> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/ini.xml?view=markup&rev=1.1 Index: phpdoc-de/reference/datetime/ini.xml +++ phpdoc-de/reference/datetime/ini.xml <?xml version="1.0" encoding="iso-8859-1"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.7 Maintainer: hholzgra Status: ready --> <section xml:id="datetime.configuration" xmlns="http://docbook.org/ns/docbook"> &reftitle.runtime; &extension.runtime; <para> <table> <title>Date/Time Configuration Options</title> <tgroup cols="4"> <thead> <row> <entry>Name</entry> <entry>Default</entry> <entry>Changeable</entry> <entry>Changelog</entry> </row> </thead> <tbody> <row> <entry>date.default_latitude</entry> <entry>"31.7667"</entry> <entry>PHP_INI_ALL</entry> <entry>Verfügbar seit PHP 5.0.0.</entry> </row> <row> <entry>date.default_longitude</entry> <entry>"35.2333"</entry> <entry>PHP_INI_ALL</entry> <entry>Verfügbar seit PHP 5.0.0.</entry> </row> <row> <entry>date.sunrise_zenith</entry> <entry>"90.583333"</entry> <entry>PHP_INI_ALL</entry> <entry>Verfügbar seit PHP 5.0.0.</entry> </row> <row> <entry>date.sunset_zenith</entry> <entry>"90.583333"</entry> <entry>PHP_INI_ALL</entry> <entry>Verfügbar seit PHP 5.0.0.</entry> </row> <row> <entry>date.timezone</entry> <entry>""</entry> <entry>PHP_INI_ALL</entry> <entry>Verfügbar seit PHP 5.1.0.</entry> </row> </tbody> </tgroup> </table> &ini.php.constants; </para> &ini.descriptions.title; <para> <variablelist> <varlistentry xml:id="ini.date.default-latitude"> <term> <parameter>date.default_latitude</parameter> <type>float</type> </term> <listitem> <para> Vorgabe-Breitengrad. </para> </listitem> </varlistentry> <varlistentry xml:id="ini.date.default-longitude"> <term> <parameter>date.default_longitude</parameter> <type>float</type> </term> <listitem> <para> Vorgabe-Längengrad. </para> </listitem> </varlistentry> <varlistentry xml:id="ini.date.sunrise-zenith"> <term> <parameter>date.sunrise_zenith</parameter> <type>float</type> </term> <listitem> <para> Vorgabe-Sonnenaufgangszenit. </para> </listitem> </varlistentry> <varlistentry xml:id="ini.date.sunset-zenith"> <term> <parameter>date.sunset_zenith</parameter> <type>float</type> </term> <listitem> <para> Vorgabe-Sonnenuntergangszenit. </para> </listitem> </varlistentry> <varlistentry xml:id="ini.date.timezone"> <term> <parameter>date.timezone</parameter> <type>string</type> </term> <listitem> <para> Diese Zeitzone wird von allen Datums- und Zeitfunktionen als Vorgabewert genutzt wenn die Umgebungsvariable <varname>TZ</varname> nicht gesetzt ist. Die Vorrangreihenfolge ist auf der Handbuchseite zu <function>date_default_timezone_get</function> beschrieben. Siehe <xref linkend="timezones"/> für eine Liste der unterstützten Zeitzonen. </para> </listitem> </varlistentry> </variablelist> </para> <note> <simpara> Die ersten vier Konfigurationsoptionen werden zur Zeit nur von den Funktionen <function>date_sunrise</function> und <function>date_sunset</function> genutzt. </simpara> </note> </section> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/setup.xml?view=markup&rev=1.1 Index: phpdoc-de/reference/datetime/setup.xml +++ phpdoc-de/reference/datetime/setup.xml <?xml version="1.0" encoding="utf-8"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.3 Maintainer: hholzgra Status: ready --> <chapter xml:id="datetime.setup" xmlns="http://docbook.org/ns/docbook" xmlns:xlink="http://www.w3.org/1999/xlink"> &reftitle.setup; <!-- {{{ Requirements --> <section xml:id="datetime.requirements"> &reftitle.required; &no.requirement; </section> <!-- }}} --> <!-- {{{ Installation --> &reference.datetime.configure; <!-- }}} --> <!-- {{{ Configuration --> &reference.datetime.ini; <!-- }}} --> <!-- {{{ Resources --> <section xml:id="datetime.resources"> &reftitle.resources; &no.resource; </section> <!-- }}} --> </chapter> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 -->
http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/reference.xml?r1=1.12&r2=1.13&diff_format=u Index: phpdoc-de/reference/datetime/reference.xml diff -u phpdoc-de/reference/datetime/reference.xml:1.12 phpdoc-de/reference/datetime/reference.xml:1.13 --- phpdoc-de/reference/datetime/reference.xml:1.12 Sun Mar 9 13:08:57 2008 +++ phpdoc-de/reference/datetime/reference.xml Sun Mar 9 13:36:06 2008 @@ -1,76 +1,15 @@ <?xml version="1.0" encoding="iso-8859-1"?> -<!-- $Revision: 1.12 $ --> -<!-- EN-Revision: 1.6 Maintainer: betz Status: ready --> -<!-- Purpose: calendar --> -<!-- Membership: core --> +<!-- $Revision: 1.13 $ --> +<!-- EN-Revision: 1.17 Maintainer: hholzgra Status: ready --> - <reference xml:id="ref.datetime" xmlns="http://docbook.org/ns/docbook"> - <title>Datums- und Zeit-Funktionen</title> - <titleabbrev>Datum/Zeit</titleabbrev> - <partintro> - <section xml:id="datetime.intro"> - &reftitle.intro; - <para> - Diese Funktionen ermöglichen es Ihnen, Datums- - und Zeitangaben vom Server, auf dem PHP läuft, abzufragen. - Die Ausgabe von Datums- und Zeitangaben kann mit Hilfe dieser Funktionen - in unterschiedlichster Weise formatiert werden. - </para> - <note> - <simpara> - Beachten Sie bitte, dass diese Funktionen von den lokalen - Systemeinstellungen Ihres Servers abhängen. Ein besonderes Augenmerk - sollten Sie auf Sommer- und Winterzeit (nutzen Sie z.B. - <literal>$date = strtotime('+7 days', $date)</literal> und nicht - <literal>$date += 7*24*60*60</literal>) - und Schaltjahre haben. - </simpara> - </note> - <note> - <simpara> - Die in diesem Abschnitt referenzierten Zeitzonen können in - <xref linkend="timezones"/> gefunden werden. - </simpara> - </note> +<reference xml:id="ref.datetime" xmlns="http://docbook.org/ns/docbook" xmlns:xlink="http://www.w3.org/1999/xlink"> + <title>Date and Time &Functions;</title> + <titleabbrev>Date/Time</titleabbrev> - </section> - - <section xml:id="datetime.required"> - &reftitle.required; - &no.requirement; - </section> - - <section xml:id="datetime.installation"> - &reftitle.install; - &no.install; - <note> - <simpara> - Die jeweils aktuellste Version der Zeitzonen-Datenbank kann über das - PECL Paket - <link href="&url.pecl.package.get;timezonedb">timezonedb</link> - installiert werden. - Für Windows Benutzer stehet eine vorkompilierte DLL auf der PECL4Win - Website bereit: - <link href="&url.pecl.timezonedb.dll;">php_timezonedb.dll</link>. - </simpara> - </note> - </section> - - <section xml:id="datetime.resources"> - &reftitle.resources; - &no.resource; - </section> - - <section xml:id="datetime.constants"> - &reftitle.constants; - &no.constants; - </section> - - </partintro> + &reference.datetime.entities.functions; -&reference.datetime.entities.functions; +</reference> - </reference> <!-- Keep this comment at the end of the file Local variables: mode: sgml @@ -91,3 +30,4 @@ vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> + http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/book.xml?view=markup&rev=1.1 Index: phpdoc-de/reference/datetime/book.xml +++ phpdoc-de/reference/datetime/book.xml <?xml version="1.0" encoding="iso-8859-1"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.2 Maintainer: hholzgra Status: ready --> <!-- Purpose: calendar --> <!-- Membership: core --> <book xml:id="book.datetime" xmlns="http://docbook.org/ns/docbook" xmlns:xlink="http://www.w3.org/1999/xlink"> <title>Datum und Uhrzeit</title> <!-- {{{ preface --> <preface xml:id="intro.datetime"> &reftitle.intro; <para> Diese Funktionen ermöglichen es Ihnen, Datums- und Zeitangaben vom Server, auf dem PHP läuft, abzufragen. Die Ausgabe von Datums- und Zeitangaben kann mit Hilfe dieser Funktionen in unterschiedlichster Weise formatiert werden. </para> <note> <simpara> Beachten Sie bitte, dass diese Funktionen von den lokalen Systemeinstellungen Ihres Servers abhängen. Ein besonderes Augenmerk sollten Sie auf Sommer- und Winterzeit (nutzen Sie z.B. <literal>$date = strtotime('+7 days', $date)</literal> und nicht <literal>$date += 7*24*60*60</literal>) und Schaltjahre haben. </simpara> </note> <note> <simpara> Die in diesem Abschnitt referenzierten Zeitzonen können in <xref linkend="timezones"/> gefunden werden. </simpara> </note> </preface> <!-- }}} --> &reference.datetime.setup; &reference.datetime.constants; <!-- FIXME: Apparently this extension defines a class.. --> &reference.datetime.reference; </book> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/configure.xml?view=markup&rev=1.1 Index: phpdoc-de/reference/datetime/configure.xml +++ phpdoc-de/reference/datetime/configure.xml <?xml version="1.0" encoding="utf-8"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.1 Maintainer: hholzgra Status: ready --> <section xml:id="datetime.installation" xmlns="http://docbook.org/ns/docbook" xmlns:xlink="http://www.w3.org/1999/xlink"> &reftitle.install; &no.install; <note> <title>Aktualisieren der Zeitzonen-Datenbank</title> <simpara> Die jeweils aktuellste Version der Zeitzonen-Datenbank kann über das PECL Paket <link href="&url.pecl.package.get;timezonedb">timezonedb</link> installiert werden. Für Windows Benutzer stehet eine vorkompilierte DLL auf der PECL4Win Website bereit: <link href="&url.pecl.timezonedb.dll;">php_timezonedb.dll</link>. </simpara> </note> <note> <title>Experimental DateTime support in PHP 5.1.x</title> <para> Obwohl die Klasse <classname>DateTime</classname> (und damit zusammenängende Funktionen) erst seit PHP 5.2.0 standardmäÃig aktiviert sind ist es möglich experimentellen Support hierfür bereits in PHP 5.1.x mit Hilfe des volgenden Flags vor <literal>configure</literal> zu aktivieren: <literal>CFLAGS=-DEXPERIMENTAL_DATE_SUPPORT=1</literal> </para> </note> </section> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/constants.xml?view=markup&rev=1.1 Index: phpdoc-de/reference/datetime/constants.xml +++ phpdoc-de/reference/datetime/constants.xml <?xml version='1.0' encoding='iso-8859-1'?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.12 Maintainer: hholzgra Status: ready --> <appendix xml:id="datetime.constants" xmlns="http://docbook.org/ns/docbook"> &reftitle.constants; <para> Die folgenden Konstanten sind ab PHP 5.1.1 definiert und bieten vorbereitetet Standard-Datenformate, diese können zusammen mit den Datumsfunktionen (wie <function>date</function>) eingesetzt werden. </para> <variablelist> <varlistentry> <term> <constant>DATE_ATOM</constant> (<type>string</type>) </term> <listitem> <simpara> Atom Format (z.B. 2005-08-15T15:52:01+00:00) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_COOKIE</constant> (<type>string</type>) </term> <listitem> <simpara> HTTP Cookie Format (z.B. Monday, 15-Aug-05 15:52:01 UTC) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_ISO8601</constant> (<type>string</type>) </term> <listitem> <simpara> ISO-8601 (z.B. 2005-08-15T15:52:01+0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC822</constant> (<type>string</type>) </term> <listitem> <simpara> RFC 822 (z.B. Mon, 15 Aug 05 15:52:01 +0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC850</constant> (<type>string</type>) </term> <listitem> <simpara> RFC 850 (z.B. Monday, 15-Aug-05 15:52:01 UTC) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC1036</constant> (<type>string</type>) </term> <listitem> <simpara> RFC 1036 (z.B. Mon, 15 Aug 05 15:52:01 +0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC1123</constant> (<type>string</type>) </term> <listitem> <simpara> RFC 1123 (z.B. Mon, 15 Aug 2005 15:52:01 +0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC2822</constant> (<type>string</type>) </term> <listitem> <simpara> RFC 2822 (Mon, 15 Aug 2005 15:52:01 +0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RFC3339</constant> (<type>string</type>) </term> <listitem> <simpara> Entspricht <constant>DATE_ATOM</constant> (since PHP 5.1.3) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_RSS</constant> (<type>string</type>) </term> <listitem> <simpara> RSS (Mon, 15 Aug 2005 15:52:01 +0000) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>DATE_W3C</constant> (<type>string</type>) </term> <listitem> <simpara> World Wide Web Consortium (z.B. 2005-08-15T15:52:01+00:00) </simpara> </listitem> </varlistentry> </variablelist> <para> Die folgenden Konstanten existieren seit PHP 5.1.2, sie spezifizieren Rückgabeformate für die Funktionen <function>date_sunrise</function> und <function>date_sunset</function>. </para> <variablelist> <varlistentry> <term> <constant>SUNFUNCS_RET_TIMESTAMP</constant> (<type>integer</type>) </term> <listitem> <simpara> Timestamp </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>SUNFUNCS_RET_STRING</constant> (<type>integer</type>) </term> <listitem> <simpara> Stunde:Minute (z.B. 08:02) </simpara> </listitem> </varlistentry> <varlistentry> <term> <constant>SUNFUNCS_RET_DOUBLE</constant> (<type>integer</type>) </term> <listitem> <simpara> Sunden als FlieÃkommawert (z.B. 8.75) </simpara> </listitem> </varlistentry> </variablelist> </appendix> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/ini.xml?view=markup&rev=1.1 Index: phpdoc-de/reference/datetime/ini.xml +++ phpdoc-de/reference/datetime/ini.xml <?xml version="1.0" encoding="iso-8859-1"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.7 Maintainer: hholzgra Status: ready --> <section xml:id="datetime.configuration" xmlns="http://docbook.org/ns/docbook"> &reftitle.runtime; &extension.runtime; <para> <table> <title>Date/Time Configuration Options</title> <tgroup cols="4"> <thead> <row> <entry>Name</entry> <entry>Default</entry> <entry>Changeable</entry> <entry>Changelog</entry> </row> </thead> <tbody> <row> <entry>date.default_latitude</entry> <entry>"31.7667"</entry> <entry>PHP_INI_ALL</entry> <entry>Verfügbar seit PHP 5.0.0.</entry> </row> <row> <entry>date.default_longitude</entry> <entry>"35.2333"</entry> <entry>PHP_INI_ALL</entry> <entry>Verfügbar seit PHP 5.0.0.</entry> </row> <row> <entry>date.sunrise_zenith</entry> <entry>"90.583333"</entry> <entry>PHP_INI_ALL</entry> <entry>Verfügbar seit PHP 5.0.0.</entry> </row> <row> <entry>date.sunset_zenith</entry> <entry>"90.583333"</entry> <entry>PHP_INI_ALL</entry> <entry>Verfügbar seit PHP 5.0.0.</entry> </row> <row> <entry>date.timezone</entry> <entry>""</entry> <entry>PHP_INI_ALL</entry> <entry>Verfügbar seit PHP 5.1.0.</entry> </row> </tbody> </tgroup> </table> &ini.php.constants; </para> &ini.descriptions.title; <para> <variablelist> <varlistentry xml:id="ini.date.default-latitude"> <term> <parameter>date.default_latitude</parameter> <type>float</type> </term> <listitem> <para> Vorgabe-Breitengrad. </para> </listitem> </varlistentry> <varlistentry xml:id="ini.date.default-longitude"> <term> <parameter>date.default_longitude</parameter> <type>float</type> </term> <listitem> <para> Vorgabe-Längengrad. </para> </listitem> </varlistentry> <varlistentry xml:id="ini.date.sunrise-zenith"> <term> <parameter>date.sunrise_zenith</parameter> <type>float</type> </term> <listitem> <para> Vorgabe-Sonnenaufgangszenit. </para> </listitem> </varlistentry> <varlistentry xml:id="ini.date.sunset-zenith"> <term> <parameter>date.sunset_zenith</parameter> <type>float</type> </term> <listitem> <para> Vorgabe-Sonnenuntergangszenit. </para> </listitem> </varlistentry> <varlistentry xml:id="ini.date.timezone"> <term> <parameter>date.timezone</parameter> <type>string</type> </term> <listitem> <para> Diese Zeitzone wird von allen Datums- und Zeitfunktionen als Vorgabewert genutzt wenn die Umgebungsvariable <varname>TZ</varname> nicht gesetzt ist. Die Vorrangreihenfolge ist auf der Handbuchseite zu <function>date_default_timezone_get</function> beschrieben. Siehe <xref linkend="timezones"/> für eine Liste der unterstützten Zeitzonen. </para> </listitem> </varlistentry> </variablelist> </para> <note> <simpara> Die ersten vier Konfigurationsoptionen werden zur Zeit nur von den Funktionen <function>date_sunrise</function> und <function>date_sunset</function> genutzt. </simpara> </note> </section> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 --> http://cvs.php.net/viewvc.cgi/phpdoc-de/reference/datetime/setup.xml?view=markup&rev=1.1 Index: phpdoc-de/reference/datetime/setup.xml +++ phpdoc-de/reference/datetime/setup.xml <?xml version="1.0" encoding="utf-8"?> <!-- $Revision: 1.1 $ --> <!-- EN-Revision: 1.3 Maintainer: hholzgra Status: ready --> <chapter xml:id="datetime.setup" xmlns="http://docbook.org/ns/docbook" xmlns:xlink="http://www.w3.org/1999/xlink"> &reftitle.setup; <!-- {{{ Requirements --> <section xml:id="datetime.requirements"> &reftitle.required; &no.requirement; </section> <!-- }}} --> <!-- {{{ Installation --> &reference.datetime.configure; <!-- }}} --> <!-- {{{ Configuration --> &reference.datetime.ini; <!-- }}} --> <!-- {{{ Resources --> <section xml:id="datetime.resources"> &reftitle.resources; &no.resource; </section> <!-- }}} --> </chapter> <!-- Keep this comment at the end of the file Local variables: mode: sgml sgml-omittag:t sgml-shorttag:t sgml-minimize-attributes:nil sgml-always-quote-attributes:t sgml-indent-step:1 sgml-indent-data:t indent-tabs-mode:nil sgml-parent-document:nil sgml-default-dtd-file:"../../../manual.ced" sgml-exposed-tags:nil sgml-local-catalogs:nil sgml-local-ecat-files:nil End: vim600: syn=xml fen fdm=syntax fdl=2 si vim: et tw=78 syn=sgml vi: ts=1 sw=1 -->