#18129 [Com]: Installation PHP 4.2.X with Apache 2.0.x
| From: | browndude at hotmail dot com | Date: | Tue, 07 Jan 2003 01:46:43 +0000 |
| Subject: | #18129 [Com]: Installation PHP 4.2.X with Apache 2.0.x | ||
| References: | 1 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969350732@lists.php.net to get a copy of this message | ||
ID: 18129
Comment by: browndude@hotmail.com
Reported By: erik@antwerpes.de
Status: Closed
Bug Type: Documentation problem
Operating System: Win32
PHP Version: 4.3.0-dev
New Comment:
okay guys.. guess what i almost tried everything up on this page, and
finally something worked for me.
read the post "[23 Oct 2002 8:52pm] blalond@umich.edu" on this page..
very very very very helpful. Thanks to the great guy who posted that
heh. I got Windows XP Apache 2.0.43
(apache_2.0.43-win32-x86-no_ssl.msi file), with Php 4.3.0
(php-4.3.0-Win32.zip file). This is great stuff.. thanks alot to that
dude again.. he did it for me.
Previous Comments:
------------------------------------------------------------------------
[2002-12-20 19:21:12] m_m_mang@hotmail.com
i had similar trubles on win2+sp3 apache 2.0.43 & php 4.xx(cause i
tried a lot till it worked)
however i found this version (PHP Version 4.3.0RC3)
from
http://bugs.php.net/bug.php?id=17826
13 Dec 7:46am] vince@alkinos.com
OK,
corrected thanks to Edin:
# There is link on the front page:
#
# http://snaps.php.net/~edink/php-4.3.0RC3-Win32.zip
#
# Edin
Vince
may god be with them and i use the same 2lines as described on top of
the page
(
LoadModule php4_module c:/php/sapi/php4apache2.dll
AddType application/x-httpd-php .php
)
and....
it´s working ....i can´t belive it !!!!
hope that will help ......
------------------------------------------------------------------------
[2002-12-16 20:08:29] 10@email.si
Thanks, blalond@umich.edu, your recipe also FIX this error:
Event Type: Error
Event Source: Apache Service
The Apache service named reported the following error:
>>> Cannot load D:/PHP4/sapi/php4apache2.dll into server: The specified
procedure could not be found. .
For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
------------------------------------------------------------------------
[2002-11-19 03:49:31] philip@php.net
index.txt has been updated to include Apache 2 related information and
will show up in PHP 4.3.0. Also, please read the following
documentation online:
http://www.php.net/manual/en/install.apache.php
The change to index.txt can be seen here:
http://cvs.php.net/diff.php/php4/win32/install.txt?r1=1.16&r2=1.17
This bug report is closed. If you have support related questions on
this issue please use the following location:
http://www.php.net/support
It's recommended to not use Apache 2 as PHP support for it is
experimental. Thank you for the report and helping make PHP better :-)
------------------------------------------------------------------------
[2002-11-12 10:14:24] newstomail@yahoo.de
In Addition:
While checking if PHP is working keep in mind clearing the browser
cache! I thought my Apache2 server continues not work with PHP but the
only thing was Mozilla keeping in mind the last access type of the
URL...
------------------------------------------------------------------------
[2002-10-23 20:52:51] blalond@umich.edu
If you're getting
"Cannot load C:/php4/sapi/php4apache2.dll into server: The specified
module could not be found."
or
"apache: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c"
is not compatible with this version of Apache (found 20020628, need
20020903)."
I got it working and this is everything I did:
1. Download:
a. Apache: apache_2.0.43-win32-x86-no_ssl.msi
b. PHP: php-4.2.3-Win32.zip
c. Latest PHP Snap:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
2. Install
a. apache
b. PHP (by upzipping and renaming dir to "c:\php"
2. Copy c:\php\php.ini-recommended to c:\windows\php.ini
3. Edit c:\php.ini
-doc_root = [current apache doc root]
-extension_dir = C:\php\extensions
4. Copy c:\php\php4ts.dll to c:\winnt\system32\
4. Copy php4apache2.dll from the c. Snap zip file to c:\php\sapi\
6. Edit Apache's configuration file and add:
LoadModule php4_module c:/php/sapi/php4apache2.dll
AddType application/x-httpd-php .php
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/18129
--
Edit this bug report at http://bugs.php.net/?id=18129&edit=1