#18129 [Csd]: Installation PHP 4.2.X with Apache 2.0.x
| From: | alindeman@php.net | Date: | Wed, 30 Apr 2003 21:32:34 +0000 |
| Subject: | #18129 [Csd]: Installation PHP 4.2.X with Apache 2.0.x | ||
| References: | 1 | Groups: | php.doc |
| Request: | Send a blank email to phpdoc+get-969352976@lists.php.net to get a copy of this message | ||
ID: 18129
Updated by: alindeman@php.net
Reported By: erik at antwerpes dot de
Status: Closed
Bug Type: Documentation problem
Operating System: Win32
PHP Version: 4.3.0-dev
New Comment:
In future, don't ask support questions here -- http://php.net/support
Previous Comments:
------------------------------------------------------------------------
[2003-04-30 16:30:34] mike at yahoo dot com
Ok, I created a text file in my htdocs <dir> to see if Apache was
recognizing .php files. Called it phptest.php and inserted only the
following... <? phpinfo(); ?>
This is what is specified on a page I used as my instruction set for
installing PHP to integrate with Apache. Here it is...
http://www.zdnet.com.au/builder/architect/sdi/story/0,2000035062,20273988,00.htm
No dice. Did not work.
Next I copied the php4ts.dll file to the Apache/bin directory. Still
no go. Finally added the line "AddModule mod_php4.c" to the AddModule
section of the Apache http.conf file.
Bingo! I typed in the url http://<MyDnsName>/phptest.php
and got it to
bring up the page. Seems like it is running now.
Good luck!
------------------------------------------------------------------------
[2003-04-30 15:39:26] mike at yahoo dot com
I read every single post on this board and tried every suggestion and
several desperate measures of my own. Even tried the registry trick
that was suggested on one of the posts by a fellow XP user. No cigar.
None of the suggestions aided me in resolving the issue that leads to
the error we are all trying to eliminate; "Cannot load
c:\php\sapi\php4apache2.dll into server".
I am running Windows XP, Apache 2.0.43 and Php 4.3.0.
Now, suppossedly php4apache.dll should NOT work with Apache 2.x. That
is what php4apache2.dll was written for. Guess what, I tried it and it
worked for me. Is it working as it should? That is another story. I
guess I'll find out soon enough.
So, bottom line...do what the guy in the [October 23rd 2002 8:52 pm]
post says if you have XP, and then try specifying the folowing in the
Apache conf file...
LoadModule php4_module x:\php\sapi\php4apache.dll
AddType application/x-httpd-php .php .php3 .php4 .phtml
May or may not work for you. To say this software is poorly documented
and experimental is an understatement!
Cheers
------------------------------------------------------------------------
[2003-01-06 19:46:43] browndude at hotmail dot com
okay guys.. guess what i almost tried everything up on this page, and
finally something worked for me.
read the post "[23 Oct 2002 8:52pm] blalond@umich.edu" on this page..
very very very very helpful. Thanks to the great guy who posted that
heh. I got Windows XP Apache 2.0.43
(apache_2.0.43-win32-x86-no_ssl.msi file), with Php 4.3.0
(php-4.3.0-Win32.zip file). This is great stuff.. thanks alot to that
dude again.. he did it for me.
------------------------------------------------------------------------
[2002-12-20 19:21:12] m_m_mang at hotmail dot com
i had similar trubles on win2+sp3 apache 2.0.43 & php 4.xx(cause i
tried a lot till it worked)
however i found this version (PHP Version 4.3.0RC3)
from
http://bugs.php.net/bug.php?id=17826
13 Dec 7:46am] vince@alkinos.com
OK,
corrected thanks to Edin:
# There is link on the front page:
#
# http://snaps.php.net/~edink/php-4.3.0RC3-Win32.zip
#
# Edin
Vince
may god be with them and i use the same 2lines as described on top of
the page
(
LoadModule php4_module c:/php/sapi/php4apache2.dll
AddType application/x-httpd-php .php
)
and....
it´s working ....i can´t belive it !!!!
hope that will help ......
------------------------------------------------------------------------
[2002-12-16 20:08:29] 10 at email dot si
Thanks, blalond@umich.edu, your recipe also FIX this error:
Event Type: Error
Event Source: Apache Service
The Apache service named reported the following error:
>>> Cannot load D:/PHP4/sapi/php4apache2.dll into server: The specified
procedure could not be found. .
For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/18129
--
Edit this bug report at http://bugs.php.net/?id=18129&edit=1