#18129 [Com]: Installation PHP 4.2.X with Apache 2.0.x

From: Date: Wed, 30 Apr 2003 20:39:27 +0000
Subject: #18129 [Com]: Installation PHP 4.2.X with Apache 2.0.x
References: 1  Groups: php.doc 
Request: Send a blank email to phpdoc+get-969352974@lists.php.net to get a copy of this message
ID: 18129 Comment by: mike at yahoo dot com Reported By: erik at antwerpes dot de Status: Closed Bug Type: Documentation problem Operating System: Win32 PHP Version: 4.3.0-dev New Comment: I read every single post on this board and tried every suggestion and several desperate measures of my own. Even tried the registry trick that was suggested on one of the posts by a fellow XP user. No cigar. None of the suggestions aided me in resolving the issue that leads to the error we are all trying to eliminate; "Cannot load c:\php\sapi\php4apache2.dll into server". I am running Windows XP, Apache 2.0.43 and Php 4.3.0. Now, suppossedly php4apache.dll should NOT work with Apache 2.x. That is what php4apache2.dll was written for. Guess what, I tried it and it worked for me. Is it working as it should? That is another story. I guess I'll find out soon enough. So, bottom line...do what the guy in the [October 23rd 2002 8:52 pm] post says if you have XP, and then try specifying the folowing in the Apache conf file... LoadModule php4_module x:\php\sapi\php4apache.dll AddType application/x-httpd-php .php .php3 .php4 .phtml May or may not work for you. To say this software is poorly documented and experimental is an understatement! Cheers Previous Comments: ------------------------------------------------------------------------ [2003-01-06 19:46:43] browndude at hotmail dot com okay guys.. guess what i almost tried everything up on this page, and finally something worked for me. read the post "[23 Oct 2002 8:52pm] blalond@umich.edu" on this page.. very very very very helpful. Thanks to the great guy who posted that heh. I got Windows XP Apache 2.0.43 (apache_2.0.43-win32-x86-no_ssl.msi file), with Php 4.3.0 (php-4.3.0-Win32.zip file). This is great stuff.. thanks alot to that dude again.. he did it for me. ------------------------------------------------------------------------ [2002-12-20 19:21:12] m_m_mang at hotmail dot com i had similar trubles on win2+sp3 apache 2.0.43 & php 4.xx(cause i tried a lot till it worked) however i found this version (PHP Version 4.3.0RC3) from http://bugs.php.net/bug.php?id=17826 13 Dec 7:46am] vince@alkinos.com OK, corrected thanks to Edin: # There is link on the front page: # # http://snaps.php.net/~edink/php-4.3.0RC3-Win32.zip # # Edin Vince may god be with them and i use the same 2lines as described on top of the page ( LoadModule php4_module c:/php/sapi/php4apache2.dll AddType application/x-httpd-php .php ) and.... it´s working ....i can´t belive it !!!! hope that will help ...... ------------------------------------------------------------------------ [2002-12-16 20:08:29] 10 at email dot si Thanks, blalond@umich.edu, your recipe also FIX this error: Event Type: Error Event Source: Apache Service The Apache service named reported the following error: >>> Cannot load D:/PHP4/sapi/php4apache2.dll into server: The specified procedure could not be found. . For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. ------------------------------------------------------------------------ [2002-11-19 03:49:31] philip@php.net index.txt has been updated to include Apache 2 related information and will show up in PHP 4.3.0. Also, please read the following documentation online: http://www.php.net/manual/en/install.apache.php The change to index.txt can be seen here: http://cvs.php.net/diff.php/php4/win32/install.txt?r1=1.16&r2=1.17 This bug report is closed. If you have support related questions on this issue please use the following location: http://www.php.net/support It's recommended to not use Apache 2 as PHP support for it is experimental. Thank you for the report and helping make PHP better :-) ------------------------------------------------------------------------ [2002-11-12 10:14:24] newstomail at yahoo dot de In Addition: While checking if PHP is working keep in mind clearing the browser cache! I thought my Apache2 server continues not work with PHP but the only thing was Mozilla keeping in mind the last access type of the URL... ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/18129 -- Edit this bug report at http://bugs.php.net/?id=18129&edit=1

« previous php.doc (#969352974) next »