Re: problem installing PHP4 with apxs & linux from newbie
| From: | Nick | Date: | Sun, 13 Aug 2000 13:15:55 +0000 |
| Subject: | Re: problem installing PHP4 with apxs & linux from newbie | ||
| References: | 1 2 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-11513@lists.php.net to get a copy of this message | ||
Hi,
I did this and it gave me the same erroe message, namely:
Cannot load /usr/local/apache/libexec/libphp4.so into server:
/usr/local/apache/libexec/libphp4.so: undefined symbol: uncompress
Please help as i am at loss as to why this could be happening. I tried loads
of different install methods and have spent a week on this problem and still
have no idea as to why it doesn't work. I even tried
specifying --with-zlib=/usr/include as this is my zlib directory, as someone
suggested this might be why i get the "uncompress" error. I run Redhat 6.2,
kernel 2.2.14-5.0, php4.0.1pl2 wityh apache 1.1.13 and mysql 1.3.23 (latest
stable)
any help greatly appreciated...
cheers,
nick
----- Original Message -----
From: Jesper Juhl <juhl@eisenstein.dk>
To: "Nick" <nick@carrierworld.com>
Sent: Saturday, August 12, 2000 5:49 PM
Subject: Re: [PHP] problem installing PHP4 with apxs & linux
First of all check your httpd.conf file for errors with the command
apachectl configtest
Fix any errors reported and try again.
If you are still unsuccessfull, then please post your ./configure line(s)
for PHP and Apache.
Best regards,
Jesper Juhl
juhl@eisenstein.dk
> Hi,
> I'm having a problem with myPHP4 installation concerning which i couldn't
find any help in the archives. After making PHP4, i try to start apache but
it gives me the message:
> Syntax error on line 207 of /usr/local/apache/conf/httpd.conf:
> Cannot load /usr/local/apache/libexec/libphp4.so into server:
/usr/local/apache/libexec/libphp4.so: undefined symbol: uncompress
> Any idea why this could be happening ? (at this point i should specify
i'm a linux newbie)
> thx for help,
> nick