RE: [PHP] HELP!! php4 module

From: Date: Mon, 14 Aug 2000 22:22:14 +0000
Subject: RE: [PHP] HELP!! php4 module
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-11697@lists.php.net to get a copy of this message
Thanks for your suggestion Kurt! I tried it without --enable-module=php4, but I still get the same error. The same error happens if I have --activate-module=src/modules/ssl/libssl.a. Could it be my httpd.conf file? I ruined it before, but I got another copy from the apache rpm and saved it in /etc/httpd/conf/httpd.conf. Regards, Adelaide On Mon, 14 Aug 2000, you wrote: > Have you tried eliminating the --enable-module=php4 part? > I haven't ever used this directive, and everything seems to > configure just fine. So it would look like this: > > cd apache_1.3.12 > ./configure --prefix=/usr \ > --sysconfdir=/etc/httpd/conf \ > --activate-module=src/modules/php4/libphp4.so \ > --enable-module=so \ > --enable-module=rewrite \ > --enable-shared=max \ > --with-perl=/usr/bin/perl \ > --with-layout=RedHat > make > > --- > Kurt A. Boyer > Advanced Software Engineer > Matchlogic, Inc. > http://www.matchlogic.com > > > -----Original Message----- > From: Adelaide Yip [mailto:adelaide.yip@compeng.net] > Sent: Monday, August 14, 2000 3:45 PM > To: php-general@lists.php.net > Subject: [PHP] HELP!! php4 module > > > Hi everyone! > > I posted this earlier, but had no responses, so I'll try again. I've looked > in > the archives but to no avail, there were no solutions. > > php 4.0.1pl2 > apache 1.3.12 > > I've installed php4 fine. The problem is with apache php4 module lines, > without them apache installs fine: > > cd apache_1.3.12 > ./configure --prefix=/usr \ > --sysconfdir=/etc/httpd/conf \ > --activate-module=src/modules/php4/libphp4.so \ > --enable-module=php4 \ > --enable-module=so \ > --enable-module=rewrite \ > --enable-shared=max \ > --with-perl=/usr/bin/perl \ > --with-layout=RedHat > make > > I get the following error: > <=== src/modules/standard > ===> src/modules/php4 > /bin/sh: ssl: No such file or directory > make[3]: *** [all] Error 1 > make[2]: *** [subdirs] Error 1 > make[2]: Leaving directory > `/home/adelaide/src/BUILD/apache_ssl-1.3.12-2.6.5/apache_1.3.12/src' > make[1]: *** [build-std] Error 2 > make[1]: Leaving directory > `/home/adelaide/src/BUILD/apache_ssl-1.3.12-2.6.5/apache_1.3.12' > make: *** [build] Error 2 > > I've already edited httpd.conf: > LoadModule modules/libphp4.so > AddModule mod_php4.c > AddType application/x-httpd-php .php .php4 .phtml > AddType application/x-httpd-php-source .phps > > Help, I don't know what else to do! Do I create php4 and move libphp4.so to > apache_1.3.12/src/modules/php4? Or is there a soft link somewhere? > > Much thanks, > AY > > -- > PHP General Mailing List (http://www.php.net/) > To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net > For additional commands, e-mail: php-general-help@lists.php.net > To contact the list administrators, e-mail: php-list-admin@lists.php.net

« previous php.general (#11697) next »