FW: [PHP] pop3 functions
| From: | Jay Blanchard | Date: | Tue, 19 Aug 2003 13:15:00 +0000 |
| Subject: | FW: [PHP] pop3 functions | ||
| Groups: | php.general | ||
| Request: | Send a blank email to php-general+get-160006@lists.php.net to get a copy of this message | ||
I will definitely agree that there are a few inconsistencies in the
function naming... more than likely due to the many many contributors,
and a lack of strict naming conventions.
Never quite understood (for example) why half of the string based
functions are named str* and the other half str_*, eg
str_replace, str_pad, str_repeat, str_word_count, etc as opposed to
strlen, strrev, strstr, strchr, strpos, etc
But all it really means is another trip to the manual if my first
"guess" for the function name doesn't work.
It'd be nice if things could have been standardised in PHP5, with
aliases to the functions with older (deprecated?) names, but I guess
it's WAAAY too late for that!!
Justin