Re: FW: [PHP] pop3 functions
| From: | Curt Zirzow | Date: | Tue, 19 Aug 2003 14:33:15 +0000 |
| Subject: | Re: FW: [PHP] pop3 functions | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-160011@lists.php.net to get a copy of this message | ||
* Thus wrote Jay Blanchard (jay.blanchard@niicommunications.com):
> I will definitely agree that there are a few inconsistencies in the
> function naming... more than likely due to the many many contributors,
> and a lack of strict naming conventions.
Actually there is a scrict nameing convetion.
>
> Never quite understood (for example) why half of the string based
> functions are named str* and the other half str_*, eg
>
> str_replace, str_pad, str_repeat, str_word_count, etc as opposed to
> strlen, strrev, strstr, strchr, strpos, etc
You'll find that the str* names are a direct decendent to the C
string library (man 3 string), and some other standard c libraries.
and the str_* names are specific to php.
>
> But all it really means is another trip to the manual if my first
> "guess" for the function name doesn't work.
>
>
> It'd be nice if things could have been standardised in PHP5, with
> aliases to the functions with older (deprecated?) names, but I guess
> it's WAAAY too late for that!!
I would strongly disagree with deprecating the str* functions. I
and a lot of php programmers know exactly what strncmp does the
instant we look at it. This nameing convetion has been around for
many years and many people have used these.
>
> Justin
Um.. is it jay or justin or both? This kind of confused me :)
Curt
--
"I used to think I was indecisive, but now I'm not so sure."