Re: PHP instalation error. PLEASE HELP!
| From: | Dezider Góra | Date: | Fri, 08 Dec 2000 15:49:05 +0000 |
| Subject: | Re: PHP instalation error. PLEASE HELP! | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-29364@lists.php.net to get a copy of this message | ||
The is:
LoadModule php4_module libexec/libphp4.so
After two hours of searching on the 'net I found something that might be
connected to it.
Full story can be found at:
http://marc.theaimsgroup.com/?l=php-general&m=97599501532213&w=2
But I have installed mysql from binary distribution - how to heck should I
solve
this?
I'll try to recompile php with that parameter and let's see...
Maybe I'll go for the mysql source and try that aproach.
Dezider
Qoute follows:
THE SOLUTION:
FIRST: MYSQL:
When compiling MySQL (from source - you can't use the binary!) - use the
"--with-lz" option like this:
./configure --prefix=/usr/local/mysql-3.23.28 --with-mysqld-user=mysql
--with-lz
SECOND: PHP4:
After you do your ./configure... [with any options you want]
After you do your "make"
THEN go find the file in the root of your PHP source folder called:
libphp4.la
Look for the lines that say:
# Libraries that this one depends upon.
dependency_libs='.... [blah blah blah] ... -lmysqlclient'
and ADD to that line, somewhere in that same line, these three characters:
-lz
THIRD: ONE LAST POSSIBLE ERROR:
If you get the error "cannot find libmysqlclient.so.10" on trying to start
Apache:
1. do a "locate" command to find what it's looking for. mine was in
"/usr/local/mysql/lib/mysql"
2. Using a text editor, open "/etc/ld.so.conf".
3. Add the directory in which the problematic file exists.
4. Save the file. Type "ldconfig".
5. go back to PHP4 compiling again. Where I wrote "SECOND: PHP4" above.
That's it!
It took me 13 hours yesterday to find out why this wasn't working, and I've
successfully installed PHP4 about 20 times in my life. Never had this many
problems. Hopefully this archived message helps someone in the future.
Much thanks to Julie Meloni's webmonkey article for the third big step at:
http://hotwired.lycos.com/webmonkey/00/44/index4a_page4.html
Alvin Tan wrote:
> Why don't you also post what line 243 is on your httpd.conf so every can see
> if there's a misconfiguration there.
>
> @lvin
>
> -----Original Message-----
> From: Dezider Góra [mailto:gora@wittmann.sk]
> Sent: Friday, December 08, 2000 9:46 PM
> To: PHP General
> Subject: [PHP] PHP instalation error. PLEASE HELP!
>
> Hi,
> desperate after five unsucsefull compilations and builds of php I'm
> turning at you guys.
> Configure seems runs ok, make too, make install too.
> But when loading httpd daemon it gives me this error:
>
> Starting httpd: Starting httpd: Syntax error on line 243 of
> /usr/local/apache/conf/httpd.conf:
> /usr/local/apache/bin/apachectl startssl: httpd could not be started
> Cannot load /usr/local/apache/libexec/libphp4.so into server:
> /usr/local/apache/libexec/libphp4.so: undefined symbol: uncompress
>
> Please help me I don't have a clue what does it mean.
>
> tia
> Dezider