Re: URGENT!!! Can't start Apache with php4 and mysql
| From: | Thomas Deliduka | Date: | Thu, 02 Aug 2001 14:15:10 +0000 |
| Subject: | Re: URGENT!!! Can't start Apache with php4 and mysql | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-60908@lists.php.net to get a copy of this message | ||
What I did was this:
ln -s /usr/local/mysql/lib/mysql/libmysqlclient.so.10
/usr/lib/libmysqlclient.so.10
(that should be only one line)
This fixed my problem.
On 8/2/2001 6:36 AM this was written:
> I have read the archives for this problem but I can't seam to fix it
> This is on a RedHat 7
> I get this error when I try to start Apache
> Starting httpd: Syntax error on line 256 of /etc/httpd/conf
> /httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server:
> libmysqlclient.so.10: cannot open shared object file: No such file
> or directory
>
> What I have read is to add the path to libmysqlclient.so.10 to the
> /etc/ld.so.conf file and then run "ldconfig". at root
> I did this but ldconfig does not run
> I keep getting No such file or directory
>
>
> This is what my ld.so.conf file looks like
> /usr/X11R6/lib
> /usr/kerberos/lib
> /usr/lib
> /usr/local/mysql
> /usr/local/mysql/lib/mysql <--This is were libmysqlclient.so.10 is
>
>
> I really need to get this working
--
Thomas Deliduka
IT Manager
-------------------------
New Eve Media
The Solution To Your Internet Angst
http://www.neweve.com/