Re: URGENT!!! Can't start Apache with php4 and mysql

From: Date: Thu, 02 Aug 2001 14:24:14 +0000
Subject: Re: URGENT!!! Can't start Apache with php4 and mysql
References: 1  Groups: php.general 
Request: Send a blank email to php-general+get-60909@lists.php.net to get a copy of this message
Richard, I've sometimes had to take a couple of swipes at this, trying both /usr/local/mysql/lib and /usr/local/mysql/lib/mysql And does libmysqlclient.so.10 have a symlink to something like libmysqlclient.so.10.0.0 And because I just checked a second machine, where mysql is installed in a completely different location, have you done a "locate" to confirm that libmysqlclient is where you expect? I know, it's like checking for gas in the tank, but sometimes .... Cheers - Miles At 03:36 AM 8/2/01 -0700, Richard Kurth wrote:
I have read the archives for this problem but I can't seam to fix it This is on a RedHat 7 I get this error when I try to start Apache Starting httpd: Syntax error on line 256 of /etc/httpd/conf /httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server: libmysqlclient.so.10: cannot open shared object file: No such file or directory What I have read is to add the path to libmysqlclient.so.10 to the /etc/ld.so.conf file and then run "ldconfig". at root I did this but ldconfig does not run I keep getting No such file or directory This is what my ld.so.conf file looks like /usr/X11R6/lib /usr/kerberos/lib /usr/lib /usr/local/mysql /usr/local/mysql/lib/mysql <--This is were libmysqlclient.so.10 is I really need to get this working Best regards, Richard mailto:rkurth@pacifier.com -- PHP General Mailing List (http://www.php.net/) To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net For additional commands, e-mail: php-general-help@lists.php.net To contact the list administrators, e-mail: php-list-admin@lists.php.net


« previous php.general (#60909) next »