Re: problem with apache php module on solaris

From: Date: Mon, 14 Jan 2002 14:47:29 +0000
Subject: Re: problem with apache php module on solaris
References: 1 2 3 4 5 6 7  Groups: php.general 
Request: Send a blank email to php-general+get-80459@lists.php.net to get a copy of this message
I think you need to add the apache module extensions to your apache configuration. try adding --enable-apxs or --with-apxs (I can remember the exact syntax) to the apache configure. ----- Original Message ----- From: "Gino Paoletti" <g.paoletti@reply.it> To: <php-general@lists.php.net> Sent: Monday, January 14, 2002 9:36 AM Subject: [PHP] problem with apache php module on solaris > Hi, I met some problems starting apache with php module on solaris 8. > > Apache is so configured: > > --prefix=/usr/local/apache-np --enable-shared=max > > The httpd -l response is: > > Compiled-in modules: > http_core.c > mod_so.c > > Php indeed: > > ./configure --prefix=/usr/local/apache-np --with-apxs=/usr/local/apache-np/b > in/apxs --with-ldap=/usr/local/ns-solaris-ldap-sdk-5/ --with-mysql=/usr/loca > l/mysql --enable-ctype --enable-sockets --enable-ftp --with-java=/usr/local/ > j2sdk1_3_1_02 --with-sybase=/usr/local/freetds > > The error is: > > Syntax error on line 223 of /usr/local/apache-np/conf/httpd.conf: > Cannot load /usr/local/apache-np/libexec/libphp4.so into server: ld.so.1: > /usr/local/apache-np/bin/httpd: fatal: relocation error: file > /usr/local/apache-np/libexec/libphp4.so: symbol uncompress: referenced > symbol not found > > Any hint?? > > Nobody steals our chickens and lives to tell. (Duke Nukem) > > Saluti Ginox. > > > -- > PHP General Mailing List (http://www.php.net/) > To unsubscribe, e-mail: php-general-unsubscribe@lists.php.net > For additional commands, e-mail: php-general-help@lists.php.net > To contact the list administrators, e-mail: php-list-admin@lists.php.net >

« previous php.general (#80459) next »