Re: intl 1.0.0RC1

From: Date: Sun, 08 Jun 2008 23:22:12 +0000
Subject: Re: intl 1.0.0RC1
References: 1 2 3 4 5 6 7 8 9 10 11  Groups: php.i18n 
Request: Send a blank email to php-i18n+get-1249@lists.php.net to get a copy of this message
>> Finally, I would like to point you to >> http://www.php.net/manual/en/userlandnaming.rules.php: >> "PHP will prefix any global symbols of an extension with the name of >> the extension." > > That's not what the real coding standard says: > > If they are part of a "parent set" of functions, that parent should > be included in the user function name, and should be clearly related > to the parent program or function family. This should be in the form > of `parent_*` That seems to be item #2 in the Naming Conventions section of: http://cvs.php.net/viewvc.cgi/php-src/CODING_STANDARDS?view=co but #7 says: "The class name should be prefixed with the name of the 'parent set' (e.g. the name of the extension)" What are the good reasons for not changing the names? Darren -- Darren Cook, Software Researcher/Developer http://dcook.org/mlsn/ (English-Japanese-German-Chinese-Arabic open source dictionary/semantic network) http://dcook.org/work/ (About me and my work) http://dcook.org/work/charts/ (My flash charting demos)

« previous php.i18n (#1249) next »