[RFC] Shorter attribute syntax

From: Date: Wed, 03 Jun 2020 23:54:57 +0000
Subject: [RFC] Shorter attribute syntax
Groups: php.internals 
Request: Send a blank email to internals+get-110355@lists.php.net to get a copy of this message
Hi internals, I discussed the syntax for attributes further with Benjamin, Martin, and several other internals developers off-list, and with their feedback completed an RFC proposing to use the shorter @@ syntax instead of <<>> for attributes in PHP 8. https://wiki.php.net/rfc/shorter_attribute_syntax The goal is not to bikeshed over subjective syntax preferences, but to address several concrete shortcomings related to verbosity, nested attributes, confusion with generics and other tokens, and dissimilarity to other common languages. Best regards, Theodore

« previous php.internals (#110355) next »