Re: [RFC] Shorter attribute syntax

From: Date: Thu, 04 Jun 2020 15:23:17 +0000
Subject: Re: [RFC] Shorter attribute syntax
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-110375@lists.php.net to get a copy of this message
> On Jun 3, 2020, at 18:54, Theodore Brown <theodorejb@outlook.com> wrote: > > Hi internals, > > I discussed the syntax for attributes further with Benjamin, Martin, > and several other internals developers off-list, and with their > feedback completed an RFC proposing to use the shorter @@ > syntax > instead of <<>> for attributes in PHP 8. > > https://wiki.php.net/rfc/shorter_attribute_syntax > > The goal is not to bikeshed over subjective syntax preferences, > but to address several concrete shortcomings related to verbosity, > nested attributes, confusion with generics and other tokens, and > dissimilarity to other common languages. After reading the RFC, I think I’m a +1 on the proposed @@ syntax. Glancing at the example code in the RFC, I think this improves readability (at least to my eyes). Cheers, Ben

Attachment: [application/pgp-signature] Message signed with OpenPGP signature.asc
« previous php.internals (#110375) next »