Re: [RFC] Add parse_query_string as an alternative to parse_str

From: Date: Fri, 06 Aug 2021 07:51:18 +0000
Subject: Re: [RFC] Add parse_query_string as an alternative to parse_str
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-115636@lists.php.net to get a copy of this message
On 06.08.2021 09:45, Mike Schinkel wrote: > I too would appreciate having a function in the PHP library that returns an array and that is > named more intuitively than parse_str(). > > However, I would suggest naming it parse_query() instead of > parse_query_string() as _string() is > redundant and I see shorter function names being preferable when the intent of the function is > clear. I agree about the _string suffix removal. However, I know we have parse_url() already, but parse_query() might be too generic. I would suggest adding "http" to the name. And as we already have http_build_query() I would rather see http_parse_query(). The RFC should target 8.2. -- Aleksander Machniak Kolab Groupware Developer [https://kolab.org] Roundcube Webmail Developer [https://roundcube.net] ---------------------------------------------------- PGP: 19359DC1 # Blog: https://kolabian.wordpress.com

« previous php.internals (#115636) next »