Re: [RFC] Add parse_query_string as an alternative to parse_str

From: Date: Fri, 06 Aug 2021 14:09:42 +0000
Subject: Re: [RFC] Add parse_query_string as an alternative to parse_str
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-115643@lists.php.net to get a copy of this message
http_parse_query() would get my vote (if I had vote karma :P) On Fri, Aug 6, 2021 at 4:05 AM Mike Schinkel <mike@newclarity.net> wrote: > > On Aug 6, 2021, at 3:51 AM, Aleksander Machniak <alec@alec.pl> wrote: > > > > I agree about the _string suffix removal. However, I know we have > > parse_url() already, but parse_query() might be too generic. I would > > suggest adding "http" to the name. And as we already have > > http_build_query() I would rather see http_parse_query(). > > +1. http_parse_query() is even better. > > -Mike > > -- > PHP Internals - PHP Runtime Development Mailing List > To unsubscribe, visit: https://www.php.net/unsub.php > >

« previous php.internals (#115643) next »