Re: Re: [RFC] Add parse_query_string as an alternative to parse_str

From: Date: Fri, 06 Aug 2021 19:42:51 +0000
Subject: Re: Re: [RFC] Add parse_query_string as an alternative to parse_str
References: 1 2 3 4  Groups: php.internals 
Request: Send a blank email to internals+get-115650@lists.php.net to get a copy of this message
Hi Internals, Thanks for all the feedback. I have changed the name to http_parse_query as it looks like more people prefer that name. I have also updated https://wiki.php.net/rfc/parse_str_alternative for 8.2 (sorry for the confusion) and I added open points. I hear two concerns currently about this RFC. Please note that my intention was to provide a simple drop-in replacement. However, I agree that there is a lot of room for improvement in this area, so I highly appreciate your comments on how we can best tackle these open points. I will not open this RFC for voting any time soon, as I want to let the conversation run through to see what other options/concerns people have. Please feel free to share your comments on what you think is the right path to improve this functionality in PHP. Regards, Kamil

« previous php.internals (#115650) next »