Re: [RFC] Random Extension 3.0
| From: | Go Kudo | Date: | Thu, 07 Oct 2021 14:00:52 +0000 |
| Subject: | Re: [RFC] Random Extension 3.0 | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-116243@lists.php.net to get a copy of this message | ||
The RFCs are in limbo, but we are currently thinking of including the
following RNGs in the proposal
- XorShift128Plus
- MT19937 (for compatibility)
- MT19937_64 (for more entropy and wider range)
While it is clear that MT19937 is simply MersenneTwister, it is not
accurate since there is MT19937_64. Also, currently, the constant name that
can be passed to mt_srand() is MT_RAND_MT19937, so I think it is consistent
to use MT19937.
If you mean that it should be MT19937 instead of MT19937_32, then I think
you are right.
Please let me know your opinion.
2021年10月7日(木) 21:56 Kamil Tekiela <tekiela246@gmail.com>:
> Please don't add more answers to the class name. There is already going to
> be a backlash if we name it "MT19973" instead of "MersenneTwister"
>