Re: RFC [Discussion]: Randomizer Additions

From: Date: Fri, 28 Oct 2022 19:30:06 +0000
Subject: Re: RFC [Discussion]: Randomizer Additions
References: 1 2 3 4  Groups: php.internals 
Request: Send a blank email to internals+get-118908@lists.php.net to get a copy of this message
Hello! [As Larry kindly pointed out to me, I only sent the email to Larry and not to the mailing list.]
"Alphabet" here still, to me, implies a character set, not a byte stream. Maybe getBytesFromString? getBytesFromList? getBytesFrom() (because you're getting it "from" the string that's provided, so you don't need another noun there.)? I'm not opposed to the functionality, but "alphabet" doesn't seem like the right word for it.
I'm not really happy with the name either and was hoping for some suggestions. getBytesFrom sounds incomplete to me. getBytesFromList sounds to me as if an array is being passed there and not a string. getBytesFromString sounds good to me, though. Better than getBytesfromAlphabet! Cheers Joshua Rüsweg

« previous php.internals (#118908) next »