Re: RFC [Discussion]: Randomizer Additions
| From: | Claude Pache | Date: | Sat, 29 Oct 2022 13:10:27 +0000 |
| Subject: | Re: RFC [Discussion]: Randomizer Additions | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-118912@lists.php.net to get a copy of this message | ||
> Le 28 oct. 2022 à 23:43, Jordan LeDoux <jordan.ledoux@gmail.com> a écrit :
>
> On Fri, Oct 28, 2022 at 12:30 PM Joshua Rüsweg via internals <
> internals@lists.php.net> wrote:
>
> Not to try and bikeshed further, but wouldn't ع'Ê{hóQ Ñ
> rzϢogetBytesFromChars or
>
getBytesFromCharList be more clear while being nearly as
> accurate?
>
> Jordan
In the face of multibyte character sets such as UTF-8, I wouldn’t use “char” to mean
“byte” (even if, in practice, the most common use will be strings of 1-byte chars).
“Alphabet” or “string” might be ambiguous (is it an alphabet of bytes or an alphabet of
characters?), but at least they are not contradictory.
—Claude