Re: RFC [Discussion]: Randomizer Additions
| From: | Jordan LeDoux | Date: | Fri, 28 Oct 2022 21:43:28 +0000 |
| Subject: | Re: RFC [Discussion]: Randomizer Additions | ||
| References: | 1 2 3 4 5 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-118909@lists.php.net to get a copy of this message | ||
On Fri, Oct 28, 2022 at 12:30 PM Joshua Rüsweg via internals <
internals@lists.php.net> wrote:
> Hello!
>
> [As Larry kindly pointed out to me, I only sent the email to Larry and
> not to the mailing list.]
>
> > "Alphabet" here still, to me, implies a character set, not a byte
> stream. Maybe getBytesFromString? getBytesFromList? getBytesFrom()
> (because you're getting it "from" the string that's provided, so you
> don't
> need another noun there.)?
> >
> > I'm not opposed to the functionality, but "alphabet" doesn't seem like
> the right word for it.
>
> I'm not really happy with the name either and was hoping for some
> suggestions.
getBytesFrom sounds incomplete to me.
> getBytesFromList
> sounds to me as if an array is being passed there and not a string.
> getBytesFromString sounds good to me, though. Better than
> getBytesfromAlphabet!
>
> Cheers
>
> Joshua Rüsweg
>
Not to try and bikeshed further, but wouldn't getBytesFromChars or
getBytesFromCharList be more clear while being nearly as accurate?
Jordan