Re: Deprecate ldap_connect with host and port as separate arguments

From: Date: Tue, 07 Feb 2023 12:55:55 +0000
Subject: Re: Deprecate ldap_connect with host and port as separate arguments
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-119478@lists.php.net to get a copy of this message
Le vendredi 27 janvier 2023, 10:00:35 CET Andreas Heigl a écrit : > Hey Folks. > > I think it would be a good idea to deprecate calling ldap_connect with 2 > parameters host and port. Hello, My long term plan was to replace it by a constructor for the new \LDAP\Connection class that only accepts the URI syntax. Which would also be better because ldap_connect is a really confusing name as it does not actually connect to anything. But I’m unfamiliar with how to write object methods into PHP modules, and I do not have much time to allocate to php-ldap. If you are interested into working on some OO methods for php-ldap classes, I have a ton of ideas on how to make it awesome. Côme

« previous php.internals (#119478) next »