Re: PHP 5.1

From: Date: Wed, 08 Jun 2005 08:23:59 +0000
Subject: Re: PHP 5.1
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-16548@lists.php.net to get a copy of this message
Hello Andi, Sunday, June 5, 2005, 9:13:52 PM, you wrote: > At 07:18 PM 6/5/2005 +0200, Marcus Boerger wrote: >>There are a few things i'd like to address before: >> >>4) I still want the ifsetor operator since it is very helpfull and again >>simplifies a lot of things. > I don't think ifsetor() shortcut is a big deal nor needed in PHP. I've said > it numerous times. Once we have a filtering API there will be even less > times where it will be applicable. Write an extra 10 characters or so... One of the major features of "ifsetor()" against "isset()?:" is that the first can be twice as fast and is much more readable. You also said numerous times it has nothing to do with input filtering :-) marcus

« previous php.internals (#16548) next »