Re: Timezone Function Name (Was: Re: [PHP-DEV] Re: [PHP-CVS] cvs: php-src / NEWS /ext/datephp_date.cphp_date.h/ext/date/tests
bug26198.phpt bug29585.phptdefault-timezone-2.phpttimezone-configuration.phpt)
| From: | Pierre-Alain Joye | Date: | Mon, 04 Jul 2005 12:21:11 +0000 |
| Subject: | Re: Timezone Function Name (Was: Re: [PHP-DEV] Re: [PHP-CVS] cvs: php-src / NEWS /ext/datephp_date.cphp_date.h/ext/date/tests bug26198.phpt bug29585.phptdefault-timezone-2.phpttimezone-configuration.phpt) |
||
| References: | 1 2 3 4 5 6 7 8 9 10 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-17114@lists.php.net to get a copy of this message | ||
On Mon, 4 Jul 2005 14:16:53 +0200 (CEST)
Derick Rethans <derick@php.net> wrote:
> > The Oslon's database changes (rarely but does :).
>
> It actually does about once a month...
I meant the amount of usefull changes. I can see some advantages to
move the TZ as an extension. It can contains only the data and can
then be easily updated.
> > Or simply allow these people
> > to use aliases from userland (means either ini or from a
> > script).
>
> Aliases from userland seems like the best way for this.
agreed
> > Last point, can you rename date_timezone_* to
> > date_default_timezone_*?
>
> Yes, but it's too long. Can we come up with something better?
default_timezone? (bye bye naming convention ;)
--Pierre