Re: Timezone Function Name (Was: Re: [PHP-DEV] Re: [PHP-CVS] cvs: php-src/ NEWS
/ext/datephp_date.cphp_date.h/ext/date/tests bug26198.phptbug29585.phptdefault-timezone-2.phpttimezone-configuration.phpt)

From: Date: Mon, 04 Jul 2005 12:35:51 +0000
Subject: Re: Timezone Function Name (Was: Re: [PHP-DEV] Re: [PHP-CVS] cvs: php-src/ NEWS
/ext/datephp_date.cphp_date.h/ext/date/tests bug26198.phptbug29585.phptdefault-timezone-2.phpttimezone-configuration.phpt)
References: 1 2 3 4 5 6 7 8 9 10 11  Groups: php.internals 
Request: Send a blank email to internals+get-17116@lists.php.net to get a copy of this message
On Mon, 4 Jul 2005 13:32:28 +0100 nlopess@php.net ("Nuno Lopes") wrote: > >> Last point, can you rename date_timezone_* to > >> date_default_timezone_*? > > > > Yes, but it's too long. Can we come up with something better? > > > > Derick > > Sorry, but I still didn't understand why the need for those > functions.. You can change the precendence in the TZ guess > internal function and you can drop that functions safely. And > without BC break, as the default for the ini option is "", that > means it will default to the TZ env var. > > Or there is something else I don't know/understand? TZ Env is painfull. Not always (or always not?) thread safe. Ini settings cannot be changed in safe mode. Regards, --Pierre

« previous php.internals (#17116) next »