Re: cvs: php-src /ext/standard string.c /ext/standard/tests/strings bug22224.phpt

From: Date: Wed, 17 Aug 2005 18:17:48 +0000
Subject: Re: cvs: php-src /ext/standard string.c /ext/standard/tests/strings bug22224.phpt
References: 1  Groups: php.cvs php.internals 
Request: Send a blank email to internals+get-18198@lists.php.net to get a copy of this message
On Aug 17, 2005, at 10:27 AM, Dmitry Stogov wrote:
Zend/zend_API.c: zend_error(error_type, "Method %s%s%s() cannot be a NULL function", scope ? scope->name : EMPTY_STR, scope ? "::" : "", ptr->fname);
This place doesn't need EMPTY_STR. ("" is enough)
If EMPTY_STR is supposed to be used only in Unicode context, we should make it clear, by naming it U_EMPTY_STR and then replacing all instances of EMPTY_STR with it or "" as necessary. -Andrei

« previous php.internals (#18198) next »