Re: SplObjectStorage

From: Date: Mon, 30 Jan 2006 18:11:53 +0000
Subject: Re: SplObjectStorage
References: 1 2 3 4 5 6  Groups: php.internals 
Request: Send a blank email to internals+get-21736@lists.php.net to get a copy of this message
On Jan 28, 2006, at 4:08 PM, Kevin Waterson wrote:
To give SplObjectStorage a better name. My best suggestion is SplUniqueObjectContainer. There may be a better choice.
Why not just call it Betty.
Why not? "Betty" is only slightly more vague than "Storage." A vague name is nobody's friend. Here is a sitepoint thread where a use of SplObjectStorage is discussed. http://www.sitepoint.com/forums/showthread.php?t=339769 I'm just trying to point out that the class may have a broader use than the context in which it was conceived and that the name could better reflect its function. AFAIK, SplObjectStorage is targeted for PHP 6. I'm not suggesting changing something that has been in PHP for half a decade. Is this not the appropriate time and place to give feedback about API design issues? Best Regards, Jeff

« previous php.internals (#21736) next »