Re: Unicode and fetch class
| From: | Andrei Zmievski | Date: | Mon, 17 Jul 2006 23:45:00 +0000 |
| Subject: | Re: Unicode and fetch class | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-24447@lists.php.net to get a copy of this message | ||
We are actually normalizing, but only identifiers.
-Andrei
On Jul 17, 2006, at 4:08 PM, Andi Gutmans wrote:
Looks OK to me. Can we call it ZEND_FETCH_CLASS_NO_LOWERCASE instead of ZEND_FETCH_CLASS_NO_NORMALIZE. No biggy but I always think of normalizing as in taking a Unicode string and normalizing it. Or is that what you're actually doing here? Asking because we agreed we won't normalize automagically in PHP.