Re: Unicode and fetch class
| From: | Andrei Zmievski | Date: | Mon, 17 Jul 2006 23:57:16 +0000 |
| Subject: | Re: Unicode and fetch class | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-24448@lists.php.net to get a copy of this message | ||
Yes, we are. But normalization (in our case) may involve case-folding (for class/function names), so it's really a single operation. If you are asking whether we should have 2 flags for it, I don't believe so.
-Andrei
On Jul 17, 2006, at 4:48 PM, Zeev Suraski wrote:
Aren't we both normalizing and lowercasing? Zeev At 02:45 18/07/2006, Andrei Zmievski wrote:We are actually normalizing, but only identifiers. -Andrei On Jul 17, 2006, at 4:08 PM, Andi Gutmans wrote:Looks OK to me. Can we call it ZEND_FETCH_CLASS_NO_LOWERCASE instead of ZEND_FETCH_CLASS_NO_NORMALIZE. No biggy but I always think of normalizing as in taking a Unicode string and normalizing it. Or is that what you're actually doing here? Asking because we agreed we won't normalize automagically in PHP.