Re: 5.3 Release Planning

From: Date: Tue, 11 Mar 2008 23:31:05 +0000
Subject: Re: 5.3 Release Planning
References: 1 2 3 4 5 6  Groups: php.internals 
Request: Send a blank email to internals+get-36102@lists.php.net to get a copy of this message
Hi!
Of course parent:: still means parent. The change in behavior from the current patch is just that once you call parent::someMethod you will still have access to overridden methods in child classes which with the current patch is not possible. Again, it just provides complete polymorphism for statics.
OK, looks like I misunderstood what your patch does. Sorry for that. However, I'm still concerned that foo:: and parent:: would work differently. IMO, better solution would be to have all :: calls change called_class, but have also some way to call it without changing called_class. Something like your forward_static_call, but I'm not sure not using callbacks is a good idea - all caller function use callbacks now. Actually, what I'd do would be to generalize forward_static_call (which I think also needs better name :) and call_user_func into one function (internally) that has parameter which tells if to update or not update called_class. -- Stanislav Malyshev, Zend Software Architect stas@zend.com http://www.zend.com/ (408)253-8829 MSN: stas@zend.com

« previous php.internals (#36102) next »