Re: 5.3 Release Planning

From: Date: Wed, 12 Mar 2008 03:42:11 +0000
Subject: Re: 5.3 Release Planning
References: 1 2 3 4 5 6 7  Groups: php.internals 
Request: Send a blank email to internals+get-36103@lists.php.net to get a copy of this message
On Tue, Mar 11, 2008 at 4:31 PM, Stanislav Malyshev <stas@zend.com> wrote: > IMO, better solution would be to have all :: calls change > called_class, but have also some way to call it without changing > called_class. Something like your forward_static_call, but I'm not sure > not using callbacks is a good idea - all caller function use callbacks > now. Actually, what I'd do would be to generalize forward_static_call > (which I think also needs better name :) and call_user_func into one > function (internally) that has parameter which tells if to update or not > update called_class. > I do agree about using a callback with forward_static_call, but one thing that worries me is that opens the door to really bizzare functionality where the called_class could wind up being outside of the inheritance chain of the method being called. If this could be overcame I think it would be relatively easy to consolidate this code internally. I will look at it this evening and tomorrow. > -- > Stanislav Malyshev, Zend Software Architect > stas@zend.com http://www.zend.com/ > (408)253-8829 MSN: stas@zend.com >

« previous php.internals (#36103) next »