Re: Re: [PATCH] LSB - new patches for forward_static_call and parent:: forwarding (was: 5.3 Release Planning)

From: Date: Thu, 20 Mar 2008 03:14:50 +0000
Subject: Re: Re: [PATCH] LSB - new patches for forward_static_call and parent:: forwarding (was: 5.3 Release Planning)
References: 1 2 3 4  Groups: php.internals 
Request: Send a blank email to internals+get-36213@lists.php.net to get a copy of this message
On Tue, Mar 18, 2008 at 4:04 PM, Etienne Kneuss <colder@php.net> wrote: > Hello, > > the forward_static_call looks like a decent non-intrusive solution, > and your patch looks > good from what I can tell! I guess you should commit it so it can be > documented and all. If by 'you' you mean me...I can't. I don't have any cvs karma, or an account for that matter. I am going to go ahead and write the tests and add them to a new copy of the patch. Then it will be ready for someone to commit. To answer Stanislav's question yes, the forward_static_call patch will suffice my concerns with the current implementation. You did mention that you weren't a big fan of the name, I am not particularly attached to it either. If you (or anyone else) has better name in mind I would be happy to change it.

« previous php.internals (#36213) next »