To answer Stanislav's question yes, the forward_static_call patch will
suffice my concerns with the current implementation. You did mention that
you weren't a big fan of the name, I am not particularly attached to it
either. If you (or anyone else) has better name in mind I would be happy to
change it.
Great. Could you just add a couple of tests - to both verify it works and illustrate the idea? Then I guess it'll be ready to commit.
--
Stanislav Malyshev, Zend Software Architect
stas@zend.com http://www.zend.com/
(408)253-8829 MSN: stas@zend.com