Re: [RFC] Improved Linux process title support in the CLI SAPI

From: Date: Thu, 07 Feb 2013 09:31:31 +0000
Subject: Re: [RFC] Improved Linux process title support in the CLI SAPI
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-65708@lists.php.net to get a copy of this message
On 7 February 2013 09:37, Christoph Rosse <crosse@2bepublished.at> wrote: > Am 2013-02-07 08:45, schrieb Alexey Zakhlestin: > >> >> On 07.02.2013, at 9:40, Keyur Govande <keyurgovande@gmail.com> wrote: >> >>> Hello, >>> >>> I've created a new RFC to improve support for setting a CLI process' >>> title >>> on Linux. It is based off of the PostgreSQL implementation and is more >>> robust than the proctitle extension. >>> >>> More details and patch here: >>> https://wiki.php.net/rfc/cli_process_title >> >> >> This would be useful for some of my tasks! >> I don't like names of functions, but I like functionality and API approach >> >> how about: >> >> bool cli_title_settable(void); This function name is ambiguous, does it mean set table or is settable, I guess it means the latter, so it should also be named like that. >> bool cli_title_set(string); >> string cli_title_get(); >> >> > > Greate feature and +1 to Alexeys function names. > > But what is the point in checking if I'm able to set a title with > is_cli_ps_title_available() if set_cli_ps_title() can fail and return false > anyway? > > I'm just asking because I don't see the benefit of the function > is_cli_ps_title_available for the user. > > > > > -- > PHP Internals - PHP Runtime Development Mailing List > To unsubscribe, visit: http://www.php.net/unsub.php > -- Regards, Mike

« previous php.internals (#65708) next »