Re: [RFC] Improved Linux process title support in the CLI SAPI

From: Date: Fri, 08 Feb 2013 23:13:31 +0000
Subject: Re: [RFC] Improved Linux process title support in the CLI SAPI
References: 1 2 3 4 5 6 7 8 9 10 11  Groups: php.internals 
Request: Send a blank email to internals+get-65737@lists.php.net to get a copy of this message
On Fri, Feb 8, 2013 at 10:16 PM, Keyur Govande <keyurgovande@gmail.com>wrote: > On Fri, Feb 8, 2013 at 4:01 PM, Ferenc Kovacs <tyra3l@gmail.com> wrote: > >> >> >> >> On Fri, Feb 8, 2013 at 9:30 PM, Keyur Govande <keyurgovande@gmail.com>wrote: >> >>> On Fri, Feb 8, 2013 at 3:20 AM, Christoph Rosse <crosse@2bepublished.at >>> >wrote: >>> >>> > Hi, >>> > >>> > could you rename these functions to: >>> > >>> > cli_process_set_title >>> > cli_process_get_title >>> > >>> > >>> > http://www.php.net/manual-**lookup.php?pattern=set_&scope=**quickref< >>> >>> http://www.php.net/manual-lookup.php?pattern=set_&scope=quickref> >>> >>> > gives me a lot of hits like: >>> > >>> > xml_parser_set_options >>> > stream_set_read_buffer >>> > pg_set_info >>> > ps_set_border_color >>> > >>> > etc. >>> > >>> > its also a lot more readable as it is: object_action_subject. >>> > >>> >>> Done. In keeping with "object_action_subject" as suggested by Christoph, >>> I >>> renamed the methods: cli_(get/set)_process_title. Patch updated: >>> https://gist.github.com/keyurdg/4728770 >>> >>> Since there's consensus around this, I'm moving this RFC to voting state. >>> >> >> I think that one day is a little bit stretching the line of the minimum >> required discussion period: >> https://wiki.php.net/rfc/voting#discussion_period >> > > Ah my bad :) I'll hold off on sending the [VOTE] email. > thanks! -- Ferenc Kovács @Tyr43l - http://tyrael.hu

« previous php.internals (#65737) next »