Re: [RFC] __debug_info()
| From: | Frédéric Hardy | Date: | Tue, 21 Jan 2014 21:42:27 +0000 |
| Subject: | Re: [RFC] __debug_info() | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-71385@lists.php.net to get a copy of this message | ||
Hi all !
Le 21 janv. 2014 à 22:26, Sara Golemon <pollita@php.net> a écrit :
> Something new to argue about:
>
> https://wiki.php.net/rfc/debug-info
Very interesting feature (i have personally thinking about that several time in the past).
However, i think that __dump() is a better name from the end user point of view.
__debug_info() is a good name from the point of view of a C developer which works on the Zend Engine
or on C extensions, but from the end user point of view, it’s not the case.
And this new magical method is used internally by var_dump() so __dump() seems to me a better name.
Maybe __set_dump() is an alternative too, because __set_state() is used internally by var_export(),
but i’m not sure that it’s a better name than __dump which is very explicit and intuitive.
Best regards,
Fred.
--
========================================================================
Frédéric Hardy : Directeur technique et fonctionnel agile
CV : http://blog.mageekbox.net/public/cv.frederic.hardy.pdf
Blog : http://blog.mageekbox.net
Twitter : http://twitter.com/mageekguy
========================================================================