Re: [RFC] __debug_info()
| From: | Santiago Lizardo | Date: | Tue, 21 Jan 2014 21:51:39 +0000 |
| Subject: | Re: [RFC] __debug_info() | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-71387@lists.php.net to get a copy of this message | ||
Sara has used stream_get_meta_data in his RFC example and I think is a good name for the new method, IMHO.
__metadata (or __get_metadata if you prefer an action/verb for methods)
Removing the debug keyword from the equation broadens the possibilities on how people might use it.
On 01/21/2014 09:42 PM, Frédéric Hardy wrote:
Hi all ! Le 21 janv. 2014 à 22:26, Sara Golemon <pollita@php.net> a écrit :-- Santiago Lizardo Oscares http://www.santiagolizardo.comSomething new to argue about: https://wiki.php.net/rfc/debug-infoVery interesting feature (i have personally thinking about that several time in the past). However, i think that __dump() is a better name from the end user point of view. __debug_info() is a good name from the point of view of a C developer which works on the Zend Engine or on C extensions, but from the end user point of view, it’s not the case. And this new magical method is used internally by var_dump() so __dump() seems to me a better name. Maybe __set_dump() is an alternative too, because __set_state() is used internally by var_export(), but i’m not sure that it’s a better name than __dump which is very explicit and intuitive. Best regards, Fred.