Re: [RFC] session_start(), read_only, lazy_write; Take 2
| From: | Julien Pauli | Date: | Fri, 28 Mar 2014 09:15:01 +0000 |
| Subject: | Re: [RFC] session_start(), read_only, lazy_write; Take 2 | ||
| References: | 1 2 3 4 5 6 7 8 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-73462@lists.php.net to get a copy of this message | ||
On Fri, Mar 28, 2014 at 8:34 AM, Yasuo Ohgaki <yohgaki@ohgaki.net> wrote:
> Hi Julien,
>
> On Wed, Mar 26, 2014 at 7:29 PM, Julien Pauli <jpauli@php.net> wrote:
>
>> > In order to avoid further arguments about whether a separate function
>> > for read-and-close is better or not, I've added an alternative
>> > proposal - to rename the option to 'read_close' or
>> > 'read_and_close'.
>> > After all, the most important thing is that it's not 'read_only'.
>>
>>
>> I agree "read_and_close" is much better discribing what it really does ,
>> so
>> I prefer it.
>
>
> I'm not sure if it's good to have "and" or not, but I'm OK with or
> without
> "and".
>
> Should I change it now?
> I mean in my github repo.
> I haven't committed the RFC patch yet.
>
Yes please.
Also, for error raising, I saw your github discussion.
We already raise errors in session functions when the session state is not
the good one at some point.
I suggest we do it as well for new session functions that's been introduced
: session_reset() and session_abort().
Leave session_write_close() as it is.
Thx.
Julien